ERP – Retorno Cobrança Escritural – Data Liberação menor que Data Pagamento
Incidente
No módulo Gestão de Contas a Receber, ao tentar processar um retorno de cobrança escritural, é apresentada a mensagem: Data Liberação menor que Data Pagamento.
Causa
Este incidente ocorre, pois no leiaute utilizado para processar o arquivo de retorno, não há tratamento para o campo DatCre (data de crédito). Como a data de liberação é alimentada de acordo com o que é recebido no campo DatCre, a partir da função AlteraCampoRetorno do leiaute, o sistema consiste e interrompe o processo, retornando a mensagem citada.
Importante
Este incidente tem ocorrido principalmente após as versões 5.10.3.122 e 5.10.4.68. Isso porque, nas versões mencionadas, a tela F301BMA - Finanças / Gestão de Contas a Receber / Contas a Receber / Baixas de Títulos / Por Lote - Automáticas não é mais acionada ao processar o retorno de cobrança escritural, conforme artigo: ERP – Retorno de Cobrança Escritural – Tela de baixa não é mais aberta após atualização do sistema. Pela rotina não chamar mais a tela F301BMA, os dados são processados de forma diferente, sendo necessário tratar a data de crédito já no leiaute de importação.
Utilizando os leiautes padrões do ERP para importação do arquivo de retorno, o problema não ocorre, visto que a data de crédito é tratada em todos os leiautes padrões.
Solução
Para que a mensagem não seja apresentada ao efetuar o retorno da cobrança escritural, realize os passos a seguir:
1. Acesse a tela Recursos / Implementações / Importação/Exportação / Editar;
2. Acesse o leiaute utilizado para importação de arquivo de retorno;
3. Ajuste para que o leiaute retorne a data de crédito. Isto pode ser feito através da função AlteraCampoRetorno, campo DatCre. Segue exemplo de como o leiaute padrão, (SAIM10002.SCF), trata os campos de data:
DatPgt e DatMov recebem a mesma data;
DatCre recebe a data que normalmente se refere à data em que o valor foi creditado em conta.
Observação
O leiaute (SAIM10002.SCF) mencionado é um exemplo. Adapte conforme sua necessidade.
Caso precise de apoio da Senior para ajuste do seu leiaute, entre em contato com a área de Serviços, para que o ajuste da customização seja realizado sob proposta comercial.