HCM - Banco de horas - Usuário não consegue adicionar lançamentos digitados no banco de horas
Incidente
No módulo Gestão do Ponto, quando utilizado diretamente por dentro da Plataforma Senior X, ao acessar o menu de Manutenção de Lançamentos do banco de horas, e clicar no botão adicionar para realizar um novo lançamento para o banco, a tela não carrega as informações do banco de horas como código do banco e situações.
Causa
Este incidente ocorre, pois o usuário não tem permissão para acessar o recurso de contas do banco de horas no módulo Gestão do Ponto da plataforma Senior X. Sem essa permissão, o sistema não carrega as informações necessárias, como o código do banco e as situações, quando o usuário tenta realizar um novo lançamento no banco de horas.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse a plataforma Senior X;
2. Vá para o menu Tecnologia / Administração / Autorização / Gestão dos papeis;
3. Selecione o papel que os gestores fazem parte;
4. Clique em Permissões e Recursos;
5. Busque pelo recurso: res://senior.com.br/rh/ponto/gestaoponto/bancoHoras/contaBancoHoras;
6. Conceda permissão de visualizar neste recurso.
Importante: Após seguir esses passos, os gestores conseguirão inserir lançamentos no banco de horas.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.