eDocs - NFS-e – Falha na solicitação com mensagem de erro: - 301 Moved Permanently
Incidente
Ao gerar uma NFS-e, no eDocs em NFS-e / Emissões, aba Emissões a nota está com o status rejeitada e ao clicar no botão Eventos, consta a seguinte informação: Falha na solicitação com mensagem de erro: 301 Moved Permanently.
Causa
O código de status 301 Moved Permanently é uma resposta HTTP que indica que o endereço solicitado foi movido permanentemente para uma nova URL e não está mais acessível no local original. Quando um navegador recebe esse status, ele redireciona automaticamente o usuário para a nova URL. Isso é frequentemente usado para redirecionamento de URL, como mover de HTTP para HTTPS.
Solução
Para solucionar isso execute os passos abaixo:
Observação: Como exemplo foi utilizado o município de Ribeirão das Neves.
1. Acesse Configurações / Consultas URL e selecione o município desejado;
2. Copie a URL que está parametrizada atualmente no eDocs, abra o navegador e cole a URL;
3. Ao executar será direcionado para o novo endereço;
4. Copie a nova URL e substitua no eDocs;
5. Após alterar a URL no eDocs para o novo endereço da prefeitura emita uma nova nota.
6. Realize a solicitação de rehomologação da prefeitura para ajuste da URL em versão oficial. Acesse o artigo ERP - eDocs NFS-e - Como solicitar homologação de uma cidade para Emissão de NFS-e e siga os passos indicado para seguir com a solicitação.
Importante: Caso não seja possível emitir a nota após alteração da URL então além da URL houve outras alterações por parte da prefeitura e será necessário aguardar a liberação da rehomologação solicitada no passo 6 para que possam ser emitidas notas normalmente através do Gestão Empresarial | ERP. Enquanto isso as emissões poderão ser realizadas diretamente no portal da prefeitura.