ERP – Faturamento – Sistema trava para todos os usuários ao realizar o processo de fechamento de notas de saída e contas a receber
Incidente
No módulo Mercado, ao realizar o processo de fechamento de notas de saída para emissão e ou processamento de contas a receber, o sistema trava por completo para todos os usuários.
Causa
Este incidente ocorre, pois o representante está informado como superior dele mesmo, ou ainda, ser superior de outro representante. Isso gera looping dentro da operação de faturamento.
Exemplo: Representante A é superior do representante B.
Representante B é superior do representante A.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o Banco de dados;
2.Execute o script abaixo, para verificar se há algum representante superior a ele mesmo ou multinível:
SELECT REPSUP,COMSUP FROM E090HRP WHERE CODREP=@P1 AND CODEMP=@P2
3. Ajuste o superior do representante;
4. Execute o processo desejado.
Importante
Através da tela o ERP não permite ter um representante superior a ele mesmo, ou superior de outro representante.
Então caso essa situação tenha ocorrido em seu ambiente, essa alteração foi realizada diretamente no banco de dados.