eDocs - RabbitMQ - Console do RabbitMQ não abre na porta XXXXX
Incidente
No módulo eDocs, ocorre falha de comunicação com o RabbitMQ, e ao tentar acessar a página do console do RabbitMQ na porta XXXXX, a página não é carregada.
Causa
Este incidente ocorre, pois os plugins do RabbitMQ não foram instalados corretamente.
Solução
Para que a página do console do RabbitMQ seja exibida, siga os passos abaixo:
1. Navegue até o diretório de instalação do RabbitMQ na basta, normalmente localizado em C:\Program Files\RabbitMQ Server\rabbitmq_server-3.7.0;
2. Acesse a pasta sbin;
3. Abra o Prompt de Comando do Windows dentro da pasta sbin;
4. Execute os seguintes comandos, separadamente:
- rabbitmq-plugins enable rabbitmq_management;
- rabbitmq-plugins enable rabbitmq_shovel;
- rabbitmq-plugins enable rabbitmq_shovel_management.
5. Tente acessar novamente o console do RabbitMQ no navegador, utilizando o endereço localhost:15762.
Para detalhes dos procedimentos para habilitação de plugins no RabbitMQ, clique aqui e consulte a documentação oficial.