Ronda Senior - Marcações - CPF ou PIS inválido
Incidente
No módulo de Marcação de Ponto, após uma migração de banco de dados de SQL para Oracle, várias marcações de ponto de diversos colaboradores em diferentes filiais foram desconsideradas, com a informação de que o CPF ou o PIS é inválido. Mesmo quando consultados na base de dados, esses dados estão corretos, e é apresentada a mensagem: CPF ou PIS inválido.
Causa
Este incidente ocorre, pois a migração de banco de dados de SQL para Oracle pode ter causado problemas na validação dos dados de CPF e PIS dos colaboradores. Mesmo que esses dados estejam corretos no banco de dados, a aplicação está considerando-os como inválidos após a migração. Isso pode estar relacionado a diferenças nas configurações regionais (NLS) entre os dois bancos de dados, o que pode afetar o formato de exibição e validação desses campos.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Verifique as configurações regionais (NLS) do banco de dados Oracle após a migração, certificando-se de que estejam configuradas corretamente;
2. Valide os logs da aplicação de Marcação de Ponto para identificar possíveis divergências na validação dos dados de CPF e PIS dos colaboradores;
3. Analise um caso específico de marcação desconsiderada, verificando se a data de acesso (DTAACC) está sendo registrada corretamente;
4. Verificar a tabela R034dac, o campo C.REPONL, o mesmo tem que estar como o (s) minúsculo e no banco oracle o mesmo tem que estar maiúsculo.