ERP MEGA - Portal de Pesquisas - Pesquisa cadastrada com resposta obrigatória está como facultativa a resposta do cliente
Incidente
No Portal de Pesquisas, ao cadastrar uma pesquisa marcando o parâmetro 'Resposta obrigatória', quando o cliente acessa a pesquisa, é apresentada a pesquisa para o cliente em tela, porém o mesmo pode fechar a pesquisa sem responder.
Causa
Este incidente ocorre, pois o parâmetro 'Resposta obrigatória', valida a obrigatoriedade de responder a questão e não a pesquisa.
Solução
Para que seja possível verificar as questões que estão como resposta obrigatória, realize os passos a seguir:
1. Acesse o Portal de Pesquisas;
2. Acesse a aba Pesquisas / Pesquisas;
3. Localize a Pesquisa e clique no botão Questões:
4. Marque o parâmetro 'Campo Obrigatório': Observação: As questões que estiverem com o parâmetro 'Campo obrigatório' marcado, serão questões obrigatórias, o cliente não poderá salvar a pesquisa antes de responder essas questões. As demais questões são facultativas, não tendo obrigatoriedade de resposta.