ERP MEGA - Portal de Clientes - Caracteres especiais apresentados como o sinal de interrogação (?)
Incidente
No Portal de Clientes, os caracteres especiais são apresentados com o sinal de interrogação (?).
Causa
Esse incidente ocorre, pois, as chaves do Oracle não estão em português.
Solução
Para que os caracteres especiais sejam apresentados corretamente, realize os passos a seguir:
1. No Servidor de Portais, clique em Iniciar / Executar;
2. Digite o comando regedit.exe;
3. Encontre a chave ORACLE;
3.1. Caso o servidor seja 32 bits, a chave encontra-se em HKEY_LOCAL_MACHINE / SOFTWARE / ORACLE;
3.2. Caso o servidor seja 64 bits, a chave encontra-se em WOW6432Node / SOFTWARE / ORACLE;
4. Na pasta do Client Oracle / Oracle Client, encontre o registro NLS_LANG:
4.1. Caso não encontre a chave, clique com o botão direito e selecione a opção Novo / Valor de Cadeia de Caracteres:
4.2. Insira o Nome NLS_LANG e clique em OK;
5. Dê duplo clique em cima da chave e altere o valor para BRAZILIAN PORTUGUESE_BRAZIL.WE8MSWIN1252;
6. Ainda na pasta Client Oracle / OracleClient, encontre o registro NLS_DATE_FORMAT:
6.1. Caso não encontre a chave, realize o passo do item 3.1 ;
6.2. Insira o nome NLS_DATE_FORMAT e clique em OK;
7. Dê duplo clique na chave e altere o valor para DD/MM/YYYY.
Atenção! Antes de realizar qualquer alteração no Editor do Registro do computador, verifique os impactos com o responsável da área de TI de sua empresa.