ERP MEGA - MDF-e - Erro na validação do SCHEMA: O elemento 'CNPJ' é inválido
Incidente
No módulo Fretes, ao gerar lote de envio a Sefaz de um MDF-e, é apresentada a mensagem: Erro na validação do SCHEMA: O elemento 'CNPJ' é inválido - O valor 'XX' é inválido dependendo do tipo de dados 'TCnpjOpc' - Falha na restrição Pattern. ** Informações da Tag: CNPJ do emitente.
Causa
Esta mensagem é apresentada, pois um dos agentes discriminados a seguir, está com o CNPJ incorreto:
- Emitente;
- Motorista;
- Destinatário;
- Condutor;
- Agente com permissão de download;
- Ajudante;
- Responsável pelo CIOT;
- Contratante;
- Responsável pelo seguro.
Solução
Para que o MDF-e seja autorizado sem apresentar a mensagem, realize os passos a seguir:
1. Acesse o módulo de Fretes, MDF-e / Processamento;
2. Filtre pelo MDF-e que apresentou a mensagem de erro de Schema;
3. Selecione o documento e clique em Ação / Visualizar dados do MDF-e;
4. Na aba geral, verifique o CNPJ do Emitente;
4.1 Ainda na aba geral, verifique o código do Motorista;
4.2 Verifique o código do Destinatário;
4.3 Na aba Geral, sub aba Condutores, verifique o(s) código(s) do agente informado;
4.4 Na aba Geral, sub aba Permissão download, verifique o(s) código(s) dos agentes com permissão de download do XML do MDF-e;
4.5 Na aba Geral, sub aba Ajudantes, verifique o código(s) do agente informado;
4.6 Na aba Geral, sub aba CIOT, verifique o código(s) do agente informado;
4.7 Na aba Geral, sub aba Contratantes, verifique o código(s) do agente informado;
4.8 Na aba Geral, sub aba Seguro, verifique o código(s) do agente informado;
5. Acesse o módulo Global, Cadastros / Agentes;
6. Filtre por todos os agentes verificados nos passos: 4, 4.1, 4.2, 4.3, 4.4, 4.5, 4.6, 4.7 e 4.8;
Observação: Realize o procedimento um agente por vez.
7. Selecione o agente filtrado e clique em Editar;
8. Na aba agente, campo CNPJ, verifique se o respectivo campo encontra-se corretamente preenchido. Caso esteja errado, realize a correção e grave a alteração.
9. Após corrigir o(s) CNPJ(s) incorretos, acesse o módulo de Fretes, MDF-e / Processamento;
10. Filtre pelo MDF-e que apresentou a mensagem do incidente;
11. Selecione o registro e clique em Ação / Gerar novo lote de envio.