ERP MEGA - Fretes - Importação de XML de NF-e - Endereço de coleta inválido
Incidente
No módulo Fretes, ao tentar processar determinado XML de NF-e importado, é apresentada a mensagem: Endereço de coleta inválido.
Causa
Esta mensagem é apresentada, pois as informações referentes ao endereço do remetente no XML importado estão em desacordo com as informações do endereço do remetente no cadastro de agentes do Mega.
As informações que podem estar em desacordo são:
- Código do endereço do agente;
- CEP;
- Sigla do Logradouro;
- Logradouro;
- Número;
- Bairro;
- Complemento;
- Código IBGE do Município;
Solução
Para que o processamento do XML da NF-e ocorra sem apresentar a mensagem, realize os passos a seguir:
1. Acesse o módulo Fretes e clique em Opções / Utilitários / Importação / NF-e;
2. Filtre pelo XML da NF-e que apresentou a mensagem;
3. Selecione-o e clique em Ação / Visualizar XML;
4. No XML, procure e verifique pelo grupo de informações do emitente da NF-e, conforme imagem a seguir:
5. Acesse o módulo Global e clique em Cadastros / Agentes;
6. Filtre pelo agente emitente da NF-e, verificado no passo 4;
7. Selecione-o, edite-o e acesse a aba Endereçamento;
8. Verifique as informações de endereço e compare-as junto as informações verificada no passo 4:
Observação: Caso o endereço do XML não seja o informado na aba Endereçamento, verifique na aba Outros Endereços se algum cadastrado atende a necessidade:
9. Ao encontrar o endereço correto e a informação do cadastro que está divergente do XML, ajuste a respectiva informação no cadastro do agente e clique em Confirmar;
10. Acesse o módulo Fretes e clique em Opções / Utilitários / Importação / NF-e;
11. Filtre pelo XML da NF-e que apresentou a mensagem, marque-a e processe-a novamente.