ERP MEGA - Approvo - Não foi possível se comunicar com o MegaConnectionManager
Incidente
No Approvo, ao tentar realizar a aprovação de um pedido de compra, é apresentada a mensagem: Não foi possível se comunicar com o MegaConnectionManager.
Causa
Esta mensagem é apresentada, pois nas versões mais recentes do Mega/Approvo (a partir da 5.00.00.57) a aprovação é realizada através do método SOAP, que envia a requisição para o Server do módulo Materiais realize a aprovação e para esse método funcionar é necessário informar o endereço de IP e a porta do servidor responsável pela execução do MegaConnectionManager.
Solução
Para realizar aprovações de pedidos de compra no Approvo, realize os seguintes passos:
1. Acesse o Approvo com um usuário Administrador;
2. Abra o Menu no canto superior esquerdo da tela e clique em Configuração / Parâmetros de Alçada;
3. Preencha o campo Endereço ConnectionManager;
4. Clique em Confirmar para salvar as alterações.
Observação: Para identificar o endereço do ConnectionManager é necessário:
Ambiente On Premise: validar com o responsável de TI para obter o endereço de IP interno do servidor responsável pela execução do MegaConnectionManager e a sua porta, que é a mesma informada no MegaConfig.xml, conforme exemplo:
Ambiente FWC: entrar em contato com o suporte FWC e solicitar o endereço de IP e porta.
Ambiente Mega Cloud: abrir um ticket no suporte para que que seja feito o preenchimento do endereço.