ERP MEGA - Approvo - Incidentes nas solicitações HTTP(S) em clientes Cloud exceto Mega Cloud
Incidente
No Approvo, para clientes que estão hospedados em clouds alternativas (que não seja Mega Cloud) pode surgir os seguintes impedimentos:
-
Falha de inicialização (Verificação da licença)
-
Falha ao gerar o QR code (O Approvo App não está disponível para este usuário)
-
Inicialização do App (One or more errors are occurred)
Causa
Estes incidentes ocorrem, por conta de uma falha de comunicação com apis externas. Nessas situações, se a cloud em questão controla as permissões de cada cliente usando contas de serviço, essa conta precisa ser informada nas configurações do IIS, na aplicação e no pool de aplicação.
Solução
Configurar aplicação no IIS
1. Abra o IIS e selecione a publicação desejada;
2. Clique na opção Advanced settings / Physical path credentials / Specific user, e digite o usuário e senha da conta de serviço;
Configurar AppPool
1. Abra o IIS e selecione a publicação desejada;
2. Clique em Basic settings, e configure o nome da Application pool;
3. No menu lateral a esquerda clique em Applications pools e localize o pool correspondente;
4. Clique em Advanced settings, em seguida selecione Identity;
5. Clique nos três pontinhos e adicione a conta de serviço.
Importante: A conta de serviço deve possuir permissões para utilização do protocolo de comunicação TLS 1.2 ou superior.