Ronda Senior – Entrega de Credencial – Erro do Banco 3931: The current transaction cannot be committed and cannot be rolled back to a savepoint. Roll back the entire transaction
Incidente
No módulo Ronda Senior, ao tentar entregar uma credencial, é apresentada a mensagem: Erro do Banco 3931: The current transaction cannot be committed and cannot be rolled back to a savepoint. Roll back the entire transaction.
Causa
Este incidente ocorre, pois há inconsistências nas tabelas da Telemática, aonde não consegue executar o comando e assim gerando cenário de Rollback.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acione a Telematica para avaliarem as tabelas, triggers e Procedures do Ambiente.
Observação: A situação pode ocorrer por alguns motivos dentro da base da Telematica, onde se faz necessário a análise do Fabricante no ambiente. No incidente pego foi visto pela telematica que faltava o Objeto s_AuxtrgRepFunc2 da telematica que resultava este retorno ao entregar uma credencial.