ERP – Pedidos – Não foi possível verificar as necessidades de produção
Incidente
No módulo de Vendas, ao tentar cancelar um item de pedido, é apresentada a mensagem: Não foi possível verificar as necessidades de produção
Causa
A situação ocorre porque o item de pedido está com o E120IPD.GerNec diferente de 1, como 2 ou 3, mas não há necessidades geradas para o item do pedido na tabela E815NBP.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse uma ferramenta de banco de sua preferência e execute o comando abaixo:
SELECT QTDNEC, QTDORP, SLDORP, CODORI FROM E815NBP WHERE CODEMP = :CODEMP AND CODFIL = :CODFIL AND NUMPED = :NUMPED AND SEQIPD = :SEQIPD AND CODPVP = :CODPVP AND CODPRO = :CODPRO AND CODDER = :CODDER AND PVPPAI = :PVPPAI AND AGRNEC = :AGRNEC AND AGRPAI = :AGRPAI
Importante
Se o comando acima não retornar resultado é porque existe uma inconsistência na base.
O item do pedido está com o E120IPD.GerNec igual a 2 ou 3, mas não foram encontradas necessidades para este item de pedido na tabela E815NBP.
2. Faça um comando auxiliar para verificar como está o GerNec.E120IPD;
SELECT GERNEC FROM E120IPD WHERE CODEMP = {EMPRESA} AND NUMPED = {PEDIDO} AND SEQIPD = {ITEM DO PEDIDO}
3. Avalie se o cenário foi causado por alguma customização, alteração via banco, ou se for por alguma ação do sistema;
3.1. Para ficar comprovado que está ocorrendo por conta de alguma ação do sistema, será necessário encaminhar evidências para o Suporte;
4. Efetue o ajuste do campo E120IPD.GerNec para o valor 1, caso queriam seguir com o cancelamento do item de pedido, e não houver nenhuma necessidade de produção gerada para esse item.