Ronda Senior – WildFly – Não foi possível iniciar a CSM Center. null
Incidente
No módulo Ronda Senior, ao tentar realizar a migração do GlassFish para WildFly, é apresentada a mensagem nos logs: Não foi possível iniciar a CSM Center. null:
Causa
Esta mensagem é retornada, pois na migração, o serviço do WildFly foi configurado no servidor de aplicação apontando para outro servidor remoto, sem realizar as parametrizações no outro ambiente.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o servidor que está instalado o serviço do WildFly;
2. Abra a pasta bin de instalação do serviço do WildFly, Exemplo: …\wildfly-30.0.1.Final\bin;
3. Entre neste diretório no cmd como administrador;
4. Informe o CreateDomainCSMCenter.bat que se encontra na pasta InstFiles, segue exemplo:
Importante: Não executar o comando nesta etapa.
5. Passe os parâmetros dessa criação de Domínio, pois a criação foi realizada através desse arquivo;
Atenção: A ordem para passar os parâmetros "%PROFILENAME% %HOST% |"%SERVERDIR%|" %HOSTCONTROLLER% %SERVERGROUP% %SERVERRUNNERNAME% %ADMINUSER% %ADMINPORT% ", seguindo a ordem pode ter o seguinte resultado:
- PROFILENAME= profile_csm_center;
- HOST= Nome da Maquina (hostname);
- SERVERDIR = Caminho do WildFly, por exemplo: C:\wildfly-30.0.1.Final\
- HOSTCONTROLLER = primary
- SERVERGROUP = sg_csmcenter
- SERVERRUNNERNAME = csmcenter
- ADMINUSER= admin
- ADMINPORT= 9990
- Caminho do Senior, por exemplo C:\Senior\
Após passar os parâmetros, ficará neste formato:
6. Informe no HOSTNAME, o nome da Maquina.
7. Execute o comando.
Importante: Caso os scripts não sejam criados no caminho: C:\WildFly\domain\servers\csmcenter\config\scripts\windows\scripts, é necessário avaliar se o Deploy foi feito com sucesso.