TMS - Importação de Conhecimentos CTE - Erro ao salvar Chave de Acesso. Documento XX já existe para a empresa XX
Incidente
No módulo UTL, ao importar um Conhecimento pela rotina Importação de Conhecimentos CTE, é apresentada a mensagem: Erro ao salvar Chave de Acesso. Documento XX já existe para a empresa XX.
Causa
Esta mensagem é apresentada, pois existe registro desse documento nas tabelas relacionadas ao Conhecimento Eletrônico.
Solução
Para que a mensagem não seja apresentada ao importar o Conhecimento, execute os passos a seguir:
1. Acesse Utilitários / SQL:
2. No STSQL, realize o login e execute, individualmente, os comandos a seguir:
2.1. SELECT *
FROM GTCCONHE
WHERE NRDOCTOFISCAL = XX
AND CDEMPRESA = XX;
2.2. SELECT *
FROM GTCCONCE
WHERE NRSEQCONTROLE = XX
AND CDEMPRESA = XX;
2.3. SELECT *
FROM GTCCONIA
WHERE NRSEQCONTROLE = XX
AND CDEMPRESA = XX;
2.4. SELECT *
FROM GTCNFCON
WHERE NRSEQCONTROLE = XX
AND CDEMPRESA = XX:
3. Em um dos comandos citados acima será apresentado o registro do documento que ocorreu o incidente de importação. Ao confirmar que se trata do mesmo documento, basta realizar o Delete do registro na tabela em que apresentou o resultado, substituindo o conteúdo 'SELECT *' por 'DELETE' e execute o comando;
4. Realize a importação do Conhecimento novamente.
- Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
- Toda e qualquer manipulação realizada via banco de dados requer cuidado!