Ronda Senior – Integração com HikVision / Intelbras – "subStatusCode": "urlDownloadFail"
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
Incidente
No módulo Ronda Senior, ao tentar integrar Faciais de HikVision/ Intelbras, é apresentada a mensagem: INFO Resposta da requisi o: [29].MinMoe(192.168.000.143). UploadPersonFaceURL person:"XXXX" name:"XXXXXXX" InboundJaxrsResponse{context=ClientResponse{method=PUT, uri=http://XXXX:80/ISAPI/Intelligent/FDLib/FDSetUp?format=json, status=400, reason=Bad Request}}
{
"statusCode": 6,
"statusString": "Invalid Content",
"subStatusCode": "urlDownloadFail",
"errorCode": 1610612846,
"errorMsg": "faceURL"
}
Causa
Existem diversas possibilidades para este retorno que envolve o Drive do equipamento que não está efetuando o Download, pode ser uma questão de Infra / Drive ou até mesmo o tamanho da foto. Outras possibilidades seriam:
- Houve um problema de comunicação quando o dispositivo tentou puxar a foto a partir da URL;
- A foto foi puxada, porém ocorreu um problema no processamento do lado do equipamento por causa de alguma característica desta (tamanho, qualidade, formato, etc.).
O situação seria necessário ser encaminhada para ser avaliada juntamente à Hikvision/ Intelbras, pois a URL está sendo acessível, porém o equipamento não está conseguindo fazer o Download.
Solução
Uma das possíveis soluções é referente a propriedade extensível, realize os passos a seguir:
1. No caminho: Ronda Senior > Projeto Físico > Cadastro;
2. Vá na Guia propriedade extensível e valide a propriedade personUpdateURL;
3. Caso a URL, esteja como Hostname, mude para o IP, deixando como HostName pode estar ocorrendo o erro no qual foi informado no Banco de soluções;
4. Após mudar para o IP, reinicie os serviços, CSM Center, Concetradora e HikVision e verifique se a situação ainda permanece.