ERP - Liberação de Pedido - Dados alterados antes ou durante o processamento
Incidente
No processo de Liberação de Pedido através da tela F120LIB_RVPE - Mercado / Gestão de Vendas / Pedidos / Aprovações / Liberação de Pedidos bloqueados, ao efetuar a liberação do pedido ocorre a mensagem indicada abaixo:
Pedidos com erros durante o processo de liberação:
Os dados do pedido foram alterados antes ou durante o processamento:
Número de pedidos: XX. Pedidos:
Filial XX. Pedido XX Dados alterados antes ou durante o processamento
Causa
A situação é causada por inconsistência entre valores dos itens do pedido (tabela E120IPD) e o valor dos dados gerais do pedido (tabela E120PED).
Geralmente a situação é causada pela alteração indevida de registros diretamente na base de dados do Pedido ou através de customizações desenvolvidas de forma incorreta (seu uso de artefatos nativos como WebServices).
Um cenário comum para esse tipo de inconsistência é um Update incorreto no campo E120IPD.SitIpd para cancelar um item do pedido, sem execução adequada do ajuste dos valores do item do pedido e do cabeçalho do pedido.
Solução
Para essa situação é necessário que você execute os seguintes passos:
1. Verifique se os valores dos itens na tabela E120IPD estão consistentes com os valores dos itens da tabela E120PED. Para executar esse processo você deverá executar comandos na base de dados do ERP (seja através de uma ferramenta do banco de dados ou do CBDS). O objetivo é você validar que a somatória dos valores dos itens seja igual aos valores armazenados no cabeçalho do pedido.
Você poderá utilizar a função SUM (somar) do banco de dados para fazer somatória de valores dos itens de pedido e comparar com os valores do cabeçalho.
Caso você não possua conhecimento técnico para fazer essa análise, verifique internamente na sua empresa um profissional que tenha esse conhecimento.
1.1. Sendo identificada a divergência de valores entre itens e cabeçalho, você deverá ajustar os valores através de comandos na base.
2. Você também poderá, como forma de solucionar esse problema:
2.1. Duplicar o pedido através da tela F120DPE_RVPE - Mercado / Gestão de Vendas / Pedidos / Manutenção de Pedidos / Duplicação, buscando gerar um novo pedido com dados consistentes.
Observação
Dependendo da inconsistência do pedido, o novo pedido gerado poderá ser gerado com inconsistência também.
2.2. Efetuar a liberação do pedido através da tela F120GPD_RVPE - Mercado / Gestão de Vendas / Pedidos / Agrupado, acessando o botão Diversos e alterando a situação de bloqueio do pedido.
Importante
Esse contorno de liberar pela tela F120GPD poderá acarretar em problemas posteriores, uma vez de que o pedido já estará com dados divergentes e inconsistentes.