HCM - Integração - Ocorreu erro na conta do colaborador XX da empresa X com o banco XX. Erro: The field CalEsM is null
Incidente
No módulo Controle de Ponto, ao efetuar a integração apresenta a mensagem: Ocorreu erro na conta do colaborador XX da empresa X com o banco XX. Erro: The field CalEsM is null.
Causa
Esta mensagem é apresentada, pois no cadastro do banco de horas, o campo calcular estouro mensal está com informação null.
Solução
Para que a mensagem não seja apresentada ao realizar a integração, realize os passos a seguir:
1. Acesse o CBDS;
1.1. Clique em Arquivo / Conectar;
1.2. Execute select na tabela R011 DEF, para localizar o cadastro que consta com campo null:
"SELECT * FROM R011 DEF"
1.3. Efetue o ajuste no módulo Gestão do Ponto;
2. Acesse Banco de Horas / Cadastro;
2.1 Selecione o banco de horas que retornou null;
2.2 Localize o campo Calcular estouro mensal;
2.3 Selecione a opção que deseja parametrizar;
2.4 Clique em alterar.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.