HCM – Assinatura ATTR – Erro ao solicitar a geração do atestado. Erro: org.apache.http.client.ClientProtocolException
Incidente
No módulo Controle de Ponto, ao tentar assinar e emitir o Atestado Técnico e Termo de Responsabilidade (ATTR) é apresentada a mensagem:Erro ao solicitar a geração do atestado. Erro: org.apache.http.client.ClientProtocolException
Causa
Este incidente ocorre devido a falha na chamada para que a Plataforma Senior X realize a assinatura digital do documento, podendo ser causado por falta de permissão ou configuração.
Solução
Para que este incidente não ocorra é necessário que o servidor de instalação do sistema atenda a alguns requisitos, realize as conferências e ajustes a seguir:
1. Acesse o servidor de instalação, o horário deve estar de acordo com horário de Brasília, realize o ajuste no Windows do servidor, pode ser pego a referência em https://time.is.
2. Acesse o módulo Controle de ponto e realize a atualização da proprietária em Diversos / Atualizar Proprietária.
3. Acesse o servidor de instalação, em um navegador de internet verifique se ele está conseguindo acessar as URLs de assinatura:
4. Acesse o SeniorConfigCenter que fica localizado no diretório de instalação do sistema, no item Chaves, insira a chave com o valor:
Chave: com.senior.vetorh.hcm.g7.location
Valor: https://platform.senior.com.br/t/senior.com.br/bridge/1.0/rest
Realize a emissão do atestado novamente.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.