ERP – eDocs Impressão – Não foi possível carregar arquivo ou assembly 'snappy64' ou uma de suas dependências. O módulo deveria conter um manifesto de assembly / Erro HRESULT E_FAIL foi retornado de uma chamada para o componente COM
Incidente
Ao solicitar impressão ou geração de algum PDF através do eDocs é gerada a seguinte mensagem em tela: Não foi possível imprimir o <Documento> número X. Verifique o arquivo de log para maiores informações.
No log (Monitor.log) são registrados as seguintes informações:
- Não foi possível gerar PDF para o documento auxiliar. Microsoft.Reporting.WebForms.LocalProcessingException: An error occurred during local report processing. ---> System.BadImageFormatException: Não foi possível carregar arquivo ou assembly 'snappy64' ou uma de suas dependências. O módulo deveria conter um manifesto de assembly.
- Não foi possível gerar PDF para o documento auxiliar. Microsoft.Reporting.WebForms.LocalProcessingException: An error occurred during local report processing. ---> System.Runtime.InteropServices.COMException: Erro HRESULT E_FAIL foi retornado de uma chamada para o componente COM.
Causa
Essa situação ocorre quando o template que está sendo utilizado para geração do PDF está sendo considerado inválido pelo Microsoft Report Viewer (componente da Microsoft que o sistema eDocs utiliza para solicitar geração do PDF).
Solução
Para verificar esta situação, verifique as orientações a seguir:
1. Verifique primeiramente o template utilizado. Ele poderá ser consultado em Configurações / Filiais, selecione a aba do documento desejado, e clique na sub-aba Impressão. Localize o campo Templates e clique em Configurar;
1.1. Se o template utilizado é o padrão da Senior, verifique se há filtros de impressão utilizando algum template desatualizado ou customizado:
1.2. Se for utilizado um template customizado, clique no botão Restaurar Padrão após selecionar o template com problemas para que o arquivo RDLC seja restaurado:
1.2.1. Contate o profissional da sua empresa responsável por sustentar esse template personalizado para que ele verifique o motivo pelo qual o erro está ocorrendo;
2. Verifique se o IIS está parametrizado corretamente com usuário Administrador do Domínio. Para maiores informações sobre a correta parametrização do IIS, verifique o artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs.
Importante
Em alguns casos, o reinício do servidor onde o eDocs está instalado pode resolver a situação.