ERP – eDocs CT-e – Crítica: 999 - Falha na solicitação com status HTTP 404: Not Found
Incidente
Ao gerar a emissão ou eventos como inutilização, carta de correção ou cancelamento de CT-e no eDocs, o mesmo fica com status Recebido ERP. Nos eventos consta a seguinte informação: Crítica: 999 - Falha na solicitação com status HTTP 404: Not Found.
A situação também poderá ocorrer sem que conste a crítica nos eventos, sendo possível verificar a crítica através do log com a mensagem: Falha na solicitação com status HTTP 404: Not Found.
A crítica também poderá ser apresentada em inglês da seguinte forma: The request failed with HTTP status 404: Not Found.
Causa
Esta situação ocorre pois o endereço do web service da SEFAZ está indisponível ou incorreto.
Importante
A incidência do endereço do web service estar incorreta tendo a ocorrer em versões desatualizadas do eDocs ou mudanças não relatadas pela SEFAZ.
Solução
Para verificar essa situação, realize os passos a seguir:
1. Acesse a tela Configurações / Consultas URL e filtre o Estado para a qual está tentando enviar o XML;
2. Acesse o portal da SEFAZ e consulte as URL do Estado para a qual está tentando enviar o XML:
3. Compare as URL que estão no eDocs com as que estão no Portal da SEFAZ;
4. Se as URL estiverem corretas, acesse o portal da SEFAZ e valide se o webservice está operacional:
5. Após o serviço da SEFAZ normalizar, o documento será transmitido de forma automática pelo eDocs.