ERP - eDocs Manifestação de Destinatário - Ciência de Operação automática não é gerada pelo eDocs
Dúvida
No processo de Geração de Ciência de Operação automaticamente, mesmo o eDocs estando parametrizado para realizar tal operação, para algumas NF-e o sistema não gera a Ciência da Operação (evento esse que pode ser verificado na tela NF-e / Manifestação de Destinatário / aba Resumos de NF-e)
Observação
A parametrização adequada para geração da Manifestação de Ciência da Operação automática é realizada na tela Configurações / Filiais / aba NF-e, ativando os parâmetros citados abaixo:
1. Ativar Recebimento;
2. Ativar consulta de manifestação;
3. Ativar a geração automática do evento de Ciência da Operação (download NF-e).
Causa
Esse incidente ocorre quando o eDocs já recebeu o XML da NF-e ao qual o Resumo da NF-e foi integrado. Ou seja, na tela NF-e / Recebimentos / aba Recebimentos a NF-e em questão estava registrada antes do momento em que o eDocs recebeu através do WebService de Distribuição de DF-e o resumo dessa mesma NF-e (resumo esse registrado na tela NF-e / Manifestação de Destinatários / aba Resumos da NF-e).
Solução
Conforme consta na Documentação do processo (Clique aqui para acessar a Documentação), no processo de geração da manifestação de Ciência de Operação automático, quando a rotina de Download Automático está habilitada, o sistema primeiramente verifica na base de dados se a NF-e (a qual haveria o registro da ciência de operação) não consta registrada na tela de Recebimento de NF-e. Caso exista, o sistema não efetua a geração da Ciência de Operação, não ativando a rotina de download automático para esta NF-e. Pois a NF-e já foi recebida por outro processo (por e-mail ou via Importador). Desta forma, só serão gerados eventos de Ciência de Operação automaticamente para as NF-e que não possuírem registro na tela de recebimento de NF-e no momento em que houver o registro da NF-e na tela Manifestação de Destinatário.
Portanto, para validar se a NF-e registrada na tela NF-e já está recebida no eDocs, execute os seguintes passos:
1. Acesse a tela NF-e / Manifestação de Destinatário / aba Resumos de NF-e do Monitor do eDocs;
2. Encontre a NF-e que você identificou que a Ciência de Operação não foi realizada e anote o número/chave de acesso desta NF-e;
3. Acesse a tela NF-e / Recebimentos / aba Recebimentos;
4. Consulte a NF-e pelo número ou chave de acesso;
5. Selecione a NF-e e acione o botão Eventos;
6. Verifique que nos eventos da NF-e haverá um evento com a descrição de Recebida fornecedor ou Importada
6.1. Caso o evento seja de Recebida fornecedor, isso indica que a NF-e foi recebida via E-mail:
6.2. Caso o evento seja de Importada, isso indica que a NF-e foi importada através do Importador do eDocs disponível na tela Inicial / Importador do Monitor do eDocs:
Observação
Como forma de validar que todas as NF-e constantes na tela NF-e / Manifestação de Destinatários / aba Resumos da NF-e estão com um registro de NF-e vinculado na tela NF-e / Recebimentos / aba Recebimentos a NF-e, pode-se executar o seguinte comando na base de dados do eDocs:
SELECT * FROM N130MAF WHERE SEQENF IS NULL
O fato desse select não retornar registros indica que está tudo correto com funcionamento do sistema.