ERP - Emissão de Boletos - Ao emitir um boleto a informação do nosso número está ficando zerada no cadastro do portador
Incidente
No módulo Gestão de Contas a Receber, o cliente utiliza a rotina de impressão de boletos e percebe que em algumas situações, o campo Nosso Número está ficando zerado no cadastro do portador.
Causa
Este incidente ocorre, pois o usuário está fazendo a impressão do boleto pelo botão ImpDocCob da tela F302CCR - Finanças / Gestão de Contas a Receber / Contas a Receber / Consultas / Títulos (Consulta de Títulos do Contas a Receber) e não possui o modelo de bloqueto devidamente parametrizado.

Solução
Para que este incidente não ocorra, realize os passos a seguir:
1. Acesse o cadastro do portador via tela NF039POR - Cadastros / Finanças / Portadores e verifique o modelo de boleto utilizado;

2. Abra o modelo através do menu Recursos > Implementações > Relatórios > Especiais > Bloqueto Financeiro;

2.1. Nessa tela, no navegador selecionar a opção Modelo > Abrir, e selecionar o modelo desejado;
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2.2. Com o modelo aberto, no navegador selecionar a opção Definição > Lógica

2.3. Selecionar a opção “N”, para o campo Gravar último número sempre:

Observação
Esta adequação no modelo deve ser feita, pois, dentro do código fonte, acionado pelo botão ImpDocCob, existe uma opção que verifica o campo “Gravar último número sempre” e espera a opção Não ou Sim. Caso esteja 'S-Sim' o sistema regrava um valor zerado no campo nosso número.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.