ERP – Envio de Boleto – Erro ao enviar boleto: Atenção para usar o recurso de envio de e-mails é necessário que todos os clientes selecionados possuam um e-mail cadastrado
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
Incidente
No módulo Gestão de Contas a Receber, ao tentar enviar um boleto automático pelo sistema, é retornada a mensagem: Erro ao enviar boleto: Atenção para usar o recurso de envio de e-mails é necessário que todos os clientes selecionados possuam um e-mail cadastrado.
Causa
Esta mensagem é retornada, pois, o identificador de regras GER-000BLQPE01 está ativo na base, dessa forma é obrigatório informar um e-mail válido no campo Endereço eletrônico (E-mail) no cadastro do cliente.
Solução
Para que a mensagem não seja apresentada ao efetuar a impressão do boleto, realize os passos a seguir:
1. Caso a impressão seja via tela, informe um endereço de e-mail válido no campo abaixo, via tela NF085CAD - Cadastros / Clientes e Fornecedores / Clientes / Cadastro (Cadastro de Clientes);

2. Caso a impressão seja via webservice, e o cliente não queira cadastrar um e-mail, efetue os passos a seguir;
2.1. Ative o parâmetro "EMPRESA.NAOCONSISTIRENVIOBOLETOCLIENTESEMEMAIL" via tela F070EMP e botão 'Par. Dinâmicos':

2.2. Com este parâmetro ativo, nas impressões de boleto via WebService, será verificado se o cliente possui e-mail cadastrado ou não.
2.2.1. Caso não possua, não será mais retornada a mensagem de Erro, e a execução será feita e o boleto não será enviado ao cliente:

2.2.2. Caso possua e-mail cadastrado, a regra vinculada ao identificador será chamada (se houver) e as validações necessárias serão feitas, validando se deve ou não fazer o envio do boleto, por exemplo:

Observação
O parâmetro influencia apenas as execuções via webservice, o processo via tela continua funcionando de forma padrão.