Konviva | Erro ao acessar conteúdo SCORM
Contexto
Ao acessar um curso com conteúdo do tipo SCORM, o aluno pode se deparar com a seguinte mensagem de erro:
“Erro ao obter o conteúdo, favor entrar em contato com o administrador.”
Esse é um erro relativamente comum e, na maioria dos casos, está relacionado à estrutura incorreta do arquivo SCORM (ZIP) enviado para a plataforma.
Causa
A principal causa desse erro é a má estruturação dentro do arquivo ZIP do SCORM.
Geralmente, o problema ocorre quando o arquivo ZIP contém apenas uma pasta na raiz, e dentro dessa pasta estão os arquivos do SCORM (como imsmanifest.xml, arquivos HTML, JS, etc.).
Ou seja, quando você abrir o arquivo ZIP e ele estiver conforme a imagem abaixo, este SCORM não irá funcionar corretamente.
Solução
Para que o conteúdo SCORM funcione corretamente, todos os arquivos devem estar diretamente na raiz do arquivo ZIP, sem estarem dentro de uma pasta adicional.
Para corrigir esse cenário, siga os passos abaixo:
Extraia o arquivo ZIP do SCORM para o seu computador.
Acesse a pasta que foi criada após a extração.
Caso exista uma pasta interna contendo os arquivos do SCORM, abra essa pasta.
Selecione todos os arquivos e pastas do SCORM (ex.:
imsmanifest.xml, arquivos HTML, pastas de recursos, etc.).Compacte os arquivos selecionados novamente em um novo arquivo ZIP.
Certifique-se de que, ao abrir o novo ZIP, os arquivos estejam diretamente na raiz, conforme a estrutura demonstrada na imagem abaixo.
Após isso, realize o upload do novo arquivo SCORM na plataforma e teste o acesso ao conteúdo.