ERP – eDocs NFS-e Joinville - Tomadores Diversos / Critica: E188 - Arquivo em desacordo com o XML Schema. | Consulte o Manual da NFS-e para saber quais são as versões de XML Schema suportadas pelo sistema
Incidente
Ao gerar uma NFS-e de tomadores diversos para a Prefeitura de Joinville, no eDocs em NFS-e / Emissões, aba Emissões a nota está com o status rejeitada e ao clicar no botão Eventos, consta a seguinte informação: Critica: E188 - Arquivo em desacordo com o XML Schema. | Consulte o Manual da NFS-e para saber quais são as versões de XML Schema suportadas pelo sistema.
Causa
A situação é causada por parametrizações incorretas no cadastro do cliente no Gestão Empresarial | ERP, relacionadas ao CPF/CNPJ.
Solução
Conforme consta no manual de integração da Prefeitura de Joinville (clique aqui para consultar o mesmo), quando se trata de uma NFS-e para Tomador Diverso o CNPJ do tomador deve ser preenchido com o valor '9999999999':
Para validar o CPF/CNPJ que está sendo utilizado na integração, efetue os passos abaixo:
1. Acesse no eDocs a tela NFS-e / Emissões, aba Emissões, localize a nota e clique no botão Visualizar:
2. Localize o campo CPF/CNPJ do Tomador do Serviço:
Para ajustar o cadastro do cliente no Gestão Empresarial | ERP, efetue os passos a seguir:
3. Acesse a tela F085CAD - Cadastros / Clientes e Fornecedores / Clientes / Cadastro, filtre o cadastro do cliente e localize o campo CNPJ/CPF:
4. Altere o valor do campo para 9999999999 e clique no botão Alterar para salvar as alterações;
5. Emita a nota novamente pela tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal, para gerar um novo XML de integração com o eDocs.
Observação
- Caso não haja possibilidade de alterar o CPF/CNPJ do cadastro do Cliente (devido ao mesmo já ter sido utilizado), é necessário que um novo cadastro seja criado para atender a necessidade de emissão no padrão Tomador Diverso;
- Em caso de validação do sistema Gestão Empresarial | ERP indicando a existência de cadastro com o mesmo CNPJ, avalie a inativação do parâmetro 'CNPJ/CPF/Nº Ident. Fiscal Cliente Repetido' na aba 'Vendas 1' da tela F070FVE - Cadastros / Filiais / Parâmetros por Gestão / Vendas, Faturamento e Transporte.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.