Serviço da CSM Center não inicia - Não gera logs
Problema:
Ao tentar iniciar o serviço Senior CSM Center pelo services.msc, é apresentada a mensagem:
O Windows não conseguiu iniciar o serviço Senior CSM Center no computador local
Erro 1067: O processo finalizou de forma inesperada
(Windows could not start the Senior CSM Center service on Local Computer.
Error 1067: The process terminated unexpectedly)
Causa:
Esta situação pode ocorrer por alguns motivos diferentes:
1 - Falta de permissão no usuário configurado no serviço;
2 - Já existe um aplicativo Java executando a aplicação em segundo plano
3 - Os arquivos do Java ou da CSM Center estão corrompidos.
Possíveis soluções:
Para cada causa acima, listaremos uma possível solução:
1 - Acesse os serviços do windows (services.msc), localize o serviço Senior CSM Center e confira o usuário configurado na aba "Logon" do serviço:
O usuário configurado deve ser um administrador local. Caso seja selecionado "conta do Sistema Local", as políticas de segurança devem dar permissão suficientes para instanciar as aplicações.
2 - Para verificar se já há um serviço da CSM Center em execução em segundo plano, abra o gerenciador de tarefas do Windows, selecione a opção "Mais detalhes", em seguida abra a guia "Detahlhes", clique com o botão direito na linha de titulos e selecione "Selecionar Colunas"
- Marque a opção "Linha de Comando"
Após atualizar, ordene a lista de processo pelo nome, e localize o serviço "java.exe".
Confira a coluna "Linha de comando" e verifique qual deles está executando de dentro da pasta "CSMCENTER":
Se encontrar, finalize o processo clicando com o botão direito sobre a linha e usando a opção "Finalizar Árvore de processos"
Depois, tente iniciar a CSM Center novamente
3 - Para verificar o estado do Java, primeiramente você deve identificar qual a pasta em uso pela CSM Center, para isso, acesse: ..\glassfish4\glasfish\config e abra o arquivo "asenv.bat"
Neste arquivo, deve haver o apontamento para a pasta do java em uso no parâmetro 'set AS_JAVA':
A pasta apontada deve ser um JDK, e não apenas um JRE. Para consultar as versões de SDK homologadas, clique aqui
Dentro da pasta, obrigatoriamente deve haver a pasta "bin":
Recomenda-se confirmar que a pasta existe e que não foi recentemente alterada, podendo indicar algum problema de instalação. Caso o java seja diferente do homologado ou a pasta esteja corrompida, baixe e instale uma versão saudável do JDK.