ERP – eDocs NFS-e – Rejeição: Arquivo enviado com erro de certificado. Certificado digital inválido - Correção: O solicitante do serviço de processamento do arquivo deve utilizar um certificado digital padrão ICP Brasil, não revogado e não expirado.
Incidente
No processo de envio de uma NFS-e para Prefeitura, a Prefeitura rejeita a NFS-e com a seguinte informação: Rejeição: Arquivo enviado com erro de certificado. Certificado digital inválido. - Correção: O solicitante do serviço de processamento do arquivo deve utilizar um certificado digital padrão ICP Brasil, não revogado e não expirado.
Causa
Essa situação ocorre devido a validação do certificado digital pela prefeitura, sendo ou uma falha de validação da prefeitura, ou alguma irregularidade com o certificado digital.
Solução
Para sanar esta situação, existem dois caminhos, que preferencialmente devem ser seguidos nesta ordem:
1. Coletar no eDocs o XML que foi transmitido à prefeitura, que resultou na rejeição.
1.1 Para habilitar o log acesse a tela Configurações / Empresa, aba Geral, localize o campo Log e parametrize para o log para que seja gerado com nível Detalhado e Coleta de XML igual à 'Sim':
Clique aqui para consultar a documentação completa relacionada aos logs.
1.2. Acesse o sistema onde a NFS-e foi emitida e gere novamente o XML da NFS-e, de forma que a rejeição ocorra novamente;
1.3. Após retornada a rejeição, acesse a tela Configurações / Logs, aba XML e nos registros, localize o XML do RPS enviado;
1.4. Envie este XML coletado à prefeitura, bem como as informações sobre a certificadora que gerou o certificado digital e a validade deste;
5. Contate a fornecedora do certificado digital e relate a situação, bem como o retorno fornecido pela prefeitura.