HCM - Apuração - Tela de Acertos de Minha Equipe recarrega continuamente e log apresenta NullPointerException
Incidente
No módulo Gestão do Ponto (Nova Interface), ao tentar acessar a tela em Acertos de Minha Equipe, a página entra em um loop de recarregamento contínuo, impedindo a sua utilização.
No arquivo de log do sistema, é apresentada a seguinte mensagem:
[#|2021-01-14T16:40:42.331-0300|SEVERE|glassfish3.1.2|br.com.senior.gp.resources.config.ServiceExceptionMapper|_ThreadID=681;_ThreadName=Thread-2;|NullPointerException:
java.lang.NullPointerException
at br.com.senior.da.facade.FacadeApuracao.trataPendenciaColaborador(FacadeApuracao.java:195)
at br.com.senior.da.facade.FacadeApuracao$Proxy$_$$_WeldClientProxy.trataPendenciaColaborador(FacadeApuracao$Proxy$_$$_WeldClientProxy.java)
at br.com.senior.da.facade.FacadeTotalizadoresColaborador.findTotalizadorPendenciasGestorCount(FacadeTotalizadoresColaborador.java:474)
...
Causa
Este incidente ocorre, pois existem campos de preenchimento obrigatório que não estão preenchidos no cadastro da Empresa, como o campo referente à 'definição de apuração'. A ausência desta informação causa o erro NullPointerException ao tentar carregar os dados dos colaboradores na tela de acertos.
Solução
Para que este incidente não ocorra:
1. Acesse a tela de cadastro da Empresa no sistema;
2. Verifique se todos os campos obrigatórios estão preenchidos, dando atenção especial ao campo de 'definição de apuração';
3. Preencha as informações nos campos que estiverem em branco e salve as alterações no cadastro;
4. Após o ajuste, acesse novamente o Gestão do Ponto e vá em Diversos / Limpar Cache e limpe o cache do módulo.
5. Acesse novamente a tela em Acertos de Minha Equipe e valide se a página carrega corretamente.