ERP – Emissão de Boleto – Ao emitir a segunda via do boleto a linha digitavel fica com a informação diferente da primeira vez
Incidente
No módulo Gestão de Contas a Receber, ao emitir a segunda via do boleto a linha digitavel fica com a informação diferente da primeira vez.
Causa
Este incidente ocorre, pois precisa fazer uma adaptação no relatório utilizado para não ocorrer esta divergência.
Casos como esses ocorrem quando o boleto é executado via WebServices com.senior.g5.co.ger.relatorio.BloquetoFinanceiro ou ação SID ExeBlo.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o gerador de relatório no menu Recursos / Implementações / Relatórios / Especiais;
1.1. Entre na propriedade DadosGerais no Evento Antes Imprimir:
1.2. Encontre a parte que menciona a carteira de cobrança:
Observação
Existe uma diferença de comportamento quando a execução ocorre através de uma requisição web, se comparado a execução local.
Esta tratativa é realizada com a função da tecnologia WSInstanciaServico(), e pode ser visto no evento Modelo Gerador /Pré-Seleção do boleto, conforme destacado abaixo:
nInstanciaServico = WSInstanciaServico();
Link para documentação da função: https://documentacao.senior.com.br/tecnologia/6.2.35/index.htm#lsp/funcoes/regra-para-web-services/wsinstanciaservico.htm
Ao executar via ação SID EXEBLO ou com o WebService com.senior.g5.co.ger.relatorio porta BloquetoFinanceiro está função retorna 1, e ao executar via tela esta função retorna 0, por isso a diferença de comportamento em ambas as situações.
A regra de negócio contida no boleto não se aplica a realidade, pois quando nInstanciaServico está com 1 é feito a busca da carteira alterando um campo chave, conforme pode ser visto no print acima.
1.3. Altere a parte do código que busca a carteira pelo campo CODCRT, e mantem apenas a busca pelo CRTBAN tirando as outras consistências, conforme abaixo:
1.4. Salve o Boleto no ícone do disquete e o problema não ocorrerá novamente.
Atenção
Sugere-se fazer um backup do relatório antes dos ajustes para que se houver algum problema, consiga reverter os ajustes. Caso seja um relatório com numeração abaixo de 100 deve ser solicitado para a Senior fazer o ajuste no relatório padrão.