HCM - Apuração - Dias duplicados na tela de acertos
Incidente
No módulo Controle de Ponto e Refeitório ou Gestão do ponto, ao abrir a tela de acertos, nota-se que há um dia duplicado na apuração.
Causa
Este incidente ocorre, pois as versões do JAVA que são utilizadas para instalação dos módulo, conta com um ajuste automático de horário de verão. Ao aplicar a diferença no horário, pode fazer com que as marcações originais apurem em dois dias simultaneamente.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Descompacte os anexos e colocar os arquivos tzupdater.jar e tzdata2019C.tar.gz nos diretórios ...Java.JDK/bin; ...Java.JDK/Jre/Bin;
2. Abra o CMD com privilégios de administrador;
2.1. Execute no CMD os comandos descritos abaixo:
CD c:/java/jdk1.8.0.121/bin java.exe -jar tzupdater.jar -l file:tzdata2019C.tar.gz -v -f
CD c:/java/jdk1.8.0.121/jre/bin java.exe -jar tzupdater.jar -l file:tzdata2019C.tar.gz -v -f
3. Reinicie os serviços do Glassfish;
4. Valide se o problema foi solucionado.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.