ERP – Relatório de Boleto – Carteira não encontrada para o banco informado
No módulo Gestão de Contas a Receber, ao tentar gerar um relatório de boleto é apresentada a mensagem: Carteira não encontrada para o banco informado.
Observação
Já foi conferido a carteira e a mesma está cadastrada.
Depurando o relatório, foi identificado que a variável FinCrtBan está em branco.
Causa
Esta mensagem é apresentada, pois o boleto foi emitido pelo gerador de relatórios e não via tela.
Solução
Para que a mensagem não seja apresentada ao tentar gerar o relatório, realize os passos a seguir:
1. Acesse a tela F302CRB_FRCR - Finanças / Gestão de Contas a Receber / Contas a Receber / Consultas / Remessas p/ Banco (Consulta de Remessa para Banco do Contas a Receber) e imprima o boleto por essa tela ou pela tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal (Emissão ou Cancelamento de Notas Fiscais de Saída).
Atenção
Ao imprimir o boleto por alguma tela do sistema a variável FinCrtBan fica com valor em memória e por isso será possível gerar o boleto.
Via gerador de relatórios ou pela opção da tela F000REL, fica guardado sempre o último número que executou por alguma tela, dessa forma se abrir o Sistema e ir direto no gerador de relatórios e tentar imprimir a variável estará vazia.
Já se for numa tela primeiro, executar o relatório e depois desejar depurar, nesse caso vai estar preenchida.