HCM – Apuração– Dias faltando na tela de acertos e/ou marcações em dias incorretos
Incidente
No módulo Gestão do Ponto, alguns dias não estão sendo mostrados na tela de acertos ou estão sendo apresentados no dia seguinte, mesmo após efetuar o cálculo de apuração sem erro.
Exemplo: O dia 04/11 não está sendo mostrado na tela de acertos e as marcações do dia 05/11 estão sendo mostradas no dia seguinte e assim sucessivamente nos demais dias.
Causa
Este incidente ocorre, pois as versões do JAVA que são utilizadas para instalação dos módulo, conta com um ajuste automático de horário de verão. Ao aplicar a diferença no horário, pode fazer com que as marcações originais apurem em dois dias simultaneamente.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Descompacte os anexos e coloque os arquivos tzupdater.zip e tzdata2019C.tar.zip nos diretórios abaixo:
<JDK>/bin;
<JDK>/Jre/Bin;
2. Execute o comando no CMD com privilégios de administrador nos diretórios acima.
Exemplo de execução dos comandos:
Iniciar > Executar > CMD;
CD c:/java/jdk1.8.0.121/bin
java.exe -jar tzupdater.jar -l file:tzdata2019C.tar.gz -v -f
CD c:/java/jdk1.8.0.121/jre/bin
java.exe -jar tzupdater.jar -l file:tzdata2019C.tar.gz -v -f
Importante:
Caso na execução dos passos acima ocorrer um erro semelhante ao print abaixo, para resolver pode ser renomeado a pasta zi por exemplo para xzi, criado novamente a pasta zi e copiado o conteúdo da pasta original. Em seguida realizar os passos acima novamente, pois não pode ocorrer o erro rename {0} to {1}, senão o processo não termina corretamente:
3. Reinicie os serviços do Glassfish;
4. Valide no Gestão do Ponto se o problema foi solucionado.
Observação:
Para saber qual é a JDK utilizada pelo Glassfish, pode-se verificar via linha de comando do processo java.exe, ou via arquivo asenv.bat (<glassfish>/glassfish/config) através da chave AS_JAVA.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.