HCM – Envio de e-mail – A mudança de remetente não é permitida
Título
HCM – Envio de e-mail – A mudança de remetente não é permitida
Incidente
No módulo Gestão do Ponto, ao enviar a pendencia de assinatura do cartão ponto, ao enviar o e-mail automático é exibido a mensagem no log de "A mudança de remetente não é permitida".
Causa
Esta mensagem é retornada, pois o servidor SMTP do cliente não aceita a troca do remetente ao utilizar o serviço de e-mail.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Abra o aplicativo SeniorConfigCenter no diretório de instalação do sistema no servidor, exemplo em 'C:/Senior';
1.1. Acesse Conexões de Rede / Envio de e-mail;
1.2. Desmarque a opção "Permitir alterar remetente".
2. Acesse as definições de assinatura em Gestão Ponto / Espelho de Ponto / Definições / Abra a Definição;
2.1. Nas opções de 'Enviar email' clique sobre Editar E-mail;
2.2 O e-mail informado no remetente deve ser o mesmo e-mail preenchido na opção Endereço do usuário de origem das mensagens configurado no passo 1.1.
Reinicie os serviços abaixo nesta sequência:
- Senior - Serviço de informações da instalação;
- Senior Middleware;
- GlassFish / Wildfly.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.