ERP - Importação de Arquivos de Retorno - Ao importar o arquivo de retorno de Cobrança Escritural, Pagamento Eletrônico, DDA ou Conciliação de Cartões o sistema fica travado e não conclui o processo
Incidente
No módulo de Finanças, ao importar o arquivo de retorno da Cobrança Escritural, Pagamento Eletrônico, DDA ou Conciliação de Cartões, o sistema trava ao buscar as informações dos títulos, sendo necessário finalizar o ERP através do gerenciador de tarefas do Windows.
Causa
Este incidente pode ocorrer nas seguintes situações: quando existe algum caracter especial no arquivo de retorno, ou quando o arquivo de retorno foi gerado em máquina com Linux, com isso a quebra de linha do arquivo não é reconhecida e o retorno do pagamento eletrônico entra em loop infinito, já que o fim do arquivo nunca é encontrado, ou ainda quando a formatação do arquivo não estiver correta, de acordo com o padrão de codificação UTF-8.
Solução
Para que este incidente não ocorra, realize os passos a seguir:
1. Abra o arquivo de retorno no notepad do Windows e verifique se existe um caracter especial, caso exista é necessário excluir o caracter;
2. Caso a situação seja a quebra de linha do arquivo, será necessário salvar no formato Windows, para isso, abra o arquivo, selecione todo o conteúdo, copie, cole em um novo bloco de notas, selecione a opção salvar como e salve como um novo arquivo;
3. Caso o problema seja a codificação UTF-8 incorreta, conforme imagem abaixo, basta selecionar todo o texto do arquivo, copiar, colar em um novo arquivo em branco:
4. No Notepad++ salve o novo arquivo utilizando a formatação "Converter para UTF8":
5. Após o salvamento, o arquivo será apresentado da seguinte forma:
6. Após realizar as correções necessárias, realize a importação do arquivo normalmente.