ERP – eDocs Impressão – Tcp channel url must have a port number: tcp://<IP>/DocumentoAuxiliarImpressao
Incidente
Ao solicitar impressão ou geração de algum PDF através do eDocs é gerada a seguinte mensagem em tela: Não foi possível imprimir o <Documento> número X. Verifique o arquivo de log para maiores informações.
No log (Sde.log) é registrado a seguinte informação: ERROR Senior.SapiensNfe.Processos.Service.Nfe.ImprimirDanfeAutomaticoNotasAutorizadas - Não foi possível emitir o <TIPO_DOCUMENTO_AUXILIAR> para <TIPO_DOCUMENTO> XXX: System.Runtime.Remoting.RemotingException: Tcp channel url must have a port number: tcp://<IP>/DocumentoAuxiliarImpressao
Observação
A mensagem Tcp channel url must have a port number poderá ser apresentada em português, sendo: A URL do canal TCP deve ter/possuir um número de porta.
Causa
Essa situação ocorre quando não for definido uma porta na URL de conexão com o PrintService:
Solução
Para verificar essa situação, siga as orientações abaixo:
1. Acesse a tela Configurações / filiais;
1.1. Selecione a aba referente ao documento que está apresentando a inconsistência na impressão;
1.2. Selecione a aba Impressão e revise o campo URL serviço de impressão.
O Endereço e Porta do serviço de impressão (Print Service) devem seguir o formato: <endereço>:<porta> da máquina onde está a instalação do Printservice.
Exemplo de parametrização correta:
Observação
Para mais informações sobre a rotina de impressão, clique aqui e acesse o Portal de Documentação Senior, pesquise por "Impressão" e localize a documentação completa desta rotina para o produto eDocs.