ERP – eDocs Impressão – Não foi possível emitir o DANFE para NFe XX: O objeto de comunicação, System.ServiceModel.Channels.ServiceChannel, não pode ser usado para comunicação porque está no estado C
Incidente
Os documentos não estão sendo impressos no eDocs (seja pela rotina automática ou pela solicitação manual). Ao verificar o log (Sde.log) é apresentado a seguinte informação: Não foi possível emitir o DANFE para NFe XX: System.ServiceModel.CommunicationObjectFaultedException: O objeto de comunicação, System.ServiceModel.Channels.ServiceChannel, não pode ser usado para comunicação porque está no estado Com Falha.
A mensagem também poderá ser apresentada em inglês:
Não foi possível emitir o DANFE para NFe XX: System.ServiceModel.CommunicationObjectFaultedException: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.
Observação
A mensagem poderá ter variações de acordo com o tipo de documento que está sendo impresso.
Causa
Essa mensagem irá ocorrer quando não houver comunicação com a Porta informada na URL de impressão do PrintService.
Solução
Para verificar se a comunicação está ocorrendo corretamente, pode-se efetuar as seguintes validações:
1. Acesse o prompt de comando do Windows e efetue um Telnet <IP_URL> <Porta>, onde:
- IP_URL: deverá ser substituído pelo número do IP informado na URL do caminho de impressão do Printservice;
- Porta: deverá ser substituído pela porta do Printservice;
2. Se o comando retornar que não conseguiu comunicação ou que está no estado com falha, verifique o acesso a esta Porta (adicionando permissões de firewall no Windows por exemplo);
Atenção
- No cadastro da filial não deve ser informado o IP e porta da impressora, mas sim do PrintService conforme consta no help da tela de configuração da filial Guia Impressão (clique aqui para acessar a documentação completa);
- O fato do eDocs não conseguir fazer a comunicação com o PrinService outra trata-se de parametrização não correta, baseado nas informações que constam no Manual de Usuário, ou algo relacionado ao ambiente do cliente, onde não é possível se comunicar com a porta de impressão.
- Para mais informações sobre a rotina de Impressão no eDocs, clique aqui para acessar a documentação completa.