ERP – eDocs Impressão – Geração de arquivos PDFs (DANFE, DANFSE, DACTE, DAMDFE) saindo com a margem cortada na impressão
Incidente
Na impressão (manual ou automática) de documentos PDFs pelo eDocs (DANFE, DANFSE, DACTE, DAMDFE), a margem está saindo cortada.
Exemplo:
Causa
A situação pode ocorrer por:
- Template customizado de forma incorreta;
- O servidor do eDocs está com problemas com a instalação de fontes, o que ocasiona o problema no template;
- Os drives da impressora estão desatualizados;
- Incompatibilidade do PrintService com alguns modelos de impressoras;
Solução
Para verificar essa situação, siga as instruções abaixo:
1. Valide os templates utilizados:
1.1. Verifique se a empresa utiliza template customizado e/ou filtros de impressão em Configurações / Empresas, aba Impressão, sub-aba NF-e (ou do respectivo documento onde está saindo cortado a impressão) e verifique os campos Templates e Filtro de impressão;
1.2. Verifique se a empresa utiliza template customizado e/ou filtros de impressão em Configurações / Filiais, aba NF-e (ou do respectivo documento onde está saindo cortado a impressão), sub-aba Impressão e verifique os campos Templates e Filtro de impressão;
2. Se for utilizado template customizado, restaure o template padrão e realize um novo teste de impressão;
3. Se o template utilizado for padrão, o servidor do eDocs está com problemas com a instalação de fontes. Altere a fonte dos campos que estão gerando o problema (através do ReportBuilder ou VisualStudio. Clique aqui e acesse o Portal de Documentação Senior, pesquise por "Configurar templates customizados" e localize a documentação completa desta rotina no módulo Ferramentas e verificações auxiliares no tópico Guia Informativo.
4. Para contornar essa situação, utilize a rotina de impressão em PDF. A rotina de impressão em PDF foi criada no sistema pois o componente PrintService pode mostrar incompatibilidade com alguns modelos de impressoras. Desta forma, esta rotina pode resolver diversas situações de impressão como, por exemplo: margem/rodapé/colunas nos arquivos auxiliares de documentos eletrônicos, problemas com as fontes na geração dos arquivos auxiliares. Clique aqui e acesse o Portal de Documentação Senior, pesquise por "Impressão em arquivo PDF" e localize a documentação completa desta rotina no eDocs.
Observação
Uma evidência de que o problema trata-se de ambiente é coletar os templates utilizados pelo eDocs onde o problema está ocorrendo, e efetuar o teste em uma versão atual do eDocs em outro ambiente. Caso o problema não ocorra, o problema está no ambiente e não no Produto eDocs. Neste caso, é necessária avaliação no ambiente onde o sistema está instalado, onde a Senior poderá apoiar através da contratação de um Consultor de TI.