HCM – Login Nova Interface – Falha no logon: Conexão Fechada EclipseLink-4002
Incidente
No módulo Gestão do Ponto, ao tentar realizar login na nova interface é apresentado a mensagem:
Ao tentar realizar o login no sistema, o erro apresentado é:
Não foi possível efetuar a autenticação.
Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.2.v20151217-774c696): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLRecoverableException: Conexão Fechada (ou Closed Connection)
Error Code: 17008 Call: SELECT TipCol, NumEmp, NumCad, CodUsu FROM r034usu WHERE (CodUsu = ?)
Query: ReadAllQuery(name=UsuarioColaborador.findByCodigoUsuario referenceClass=UsuarioColaborador
Causa
Este incidente ocorre quando a conexão com o banco de dados não está sendo estabelecida corretamente, possivelmente devido a uma configuração inadequada de conexão ou versão incompatível do driver JDBC do Glassfish.
Solução
Para que esse incidente não ocorra, realize os passos as verificações a seguir:
1. Verifique Configuração do Pool de Conexões:
1.1 Acesse o SeniorConfigCenter em:
SeniorConfigCenter / Banco de Dados / Gestão de Pessoas / Avançado
1.2 Verifique se o campo "Quantidade máxima para pool de conexões" está configurado para 250.
2. Verifique Driver JDBC:
Importante: Caso o banco de dados seja Oracle 12 ou posterior, é necessário verificar a versão do driver JDBC. O driver correto para esta versão do Oracle é o ojdbc7.jar (em vez do padrão ojdbc6.jar).
2.1 Baixe o driver correto no Portal do Cliente, em Ferramentas / Atualizações Glassfish.
2.2 Coloque o driver em: <glassfish>/glassfish/lib.
3. Altere Configuração de Pool no Glassfish:
3.1 Acesse o Console de Administração do Glassfish (exemplo: http://localhost:4848).
3.2 Vá para Resources / JDBC / gestaoponto-dataaccess
3.3 Na aba General, altere o Maximum Pool Size de 32 para 64 e clique em Save.
3.4 Na aba Advanced, marque a opção Connection Validation e configure:
Validation Method: table
Table Name: R250TAB
3.5 Clique em Save.
Atenção
Ao final de todas verificações reinicie os serviços nesta sequência e um por vez:
-Senior Serviço de Informações da instalação.
-Senior Middleware (se houver mais de um, todos devem ser reiniciados).
-Glassfish (domínios que se encontram o Gestão do Ponto).
Importante:
Verifique as permissões de acesso ao banco de dados e a estabilidade da rede, caso o problema persista.
Caso o erro continue mesmo após essas configurações, consulte o suporte técnico para investigar possíveis problemas de rede ou hardware.