ERP – eDocs NFS-e – Rejeição: RPS já informado / RPS já informada / Número da RPS já existe
Incidente
Ao gerar uma NFS-e, no eDocs em NFS-e / Emissões, aba Emissões a nota está com o status rejeitada e ao clicar no botão Eventos, consta a seguinte informação: RPS já informado.
A rejeição poderá ainda ser apresentada de outras formas, dependendo do fornecedor do sistema de cada Prefeitura:
- RPS: XX, Série: X - RPS já informada;
- Número da RPS já existe.
Causa
Essa situação ocorre por um problema no processamento das RPS enviadas para serem convertidas em NFS-e no sistema da Prefeitura.
Pode ocorrer também quando a prefeitura possui vários servidores para atendimento das requisições enviadas pelos contribuintes. Onde:
- Quando é enviado um lote de documento, o servidor A, por exemplo, recebe o lote enviado;
- Quando o eDocs envia ao sistema da Prefeitura uma consulta para verificar a situação do lote, esta requisição é atendida pelo Servidor B;
- No entanto, o Servidor B ainda não possui o registro do lote enviado (porque internamente o lote ainda não foi replicado para todos os servidores), então o Servidor B retorna que o Lote do documento enviado não existe;
- Com isso, o eDocs envia um novo lote para a Prefeitura. Desta vez, a Prefeitura retorna de que a RPS já existe, porque o primeiro lote enviado foi autorizado com sucesso, sendo apenas problemas no processamento das requisições pelos servidores da prefeitura.
Esta situação é muito comum na cidade de Belo Horizonte (fornecedor BHISS). Em anexo segue um documento que exemplifica o porque do problema ocorrer, mostrando a comunicação do eDocs com a Prefeitura via arquivos XMLs.
Solução
Uma forma de contornar essa situação é seguir as orientações abaixo:
1. Altere o parâmetro Envio lotes e Retorno lotes em Configurações / Gerais, aba Avançado, sub-aba Intervalos de Execução. O valor padrão geralmente é de 20 segundos. Poderá ser alterado para 60 segundos (ou até mais);
Observação
Essa alteração fará com que o sistema eDocs aguarde mais tempo para enviar um novo lote e consultar o status de um lote enviado, o que dará mais tempo para os servidores da Prefeitura processarem e replicarem o registro de seus lotes internamente.
2. Para as notas que já tiveram o retorno de rejeição da Prefeitura, faça o seguinte procedimento:
2. . Acesse o portal da Prefeitura e consulte o respectivo número de RPS;
2.2. Verifique o código de verificação que foi gerado para o mesmo;
2.3. No eDocs, em NFS-e / Emissões, aba Emissões clique no botão Consultar. Irá abrir a tela para ser informado o código de verificação:
2.4. Informe o código de verificação e clique no botão Salvar código e atualizar;
2.5. O sistema eDocs fará uma consulta no portal da Prefeitura onde deverá ser retornado o status da autorização da NFS-e para o eDocs.
Importante:
- Essa alteração de parâmetro fará com que o sistema eDocs aguarde mais tempo para enviar um novo lote e consultar o status de um lote enviado, o que dará mais tempo para os servidores da Prefeitura processarem e replicarem o registro de seus lotes internamente;
- O problema relatado não se trata de um problema no produto eDocs, desta forma, caso após alteração dos parâmetros o problema ainda ocorra, é necessário entrar em contato com o suporte da prefeitura que está apesentando este problema;
- Para que haja retorno do status de Autorização para o Gestão Empresarial | ERP, é necessário que a RPS esteja com status de 2-Enviada. Desta forma, se necessário, deverá ser efetuada a geração do arquivo XML da RPS atualizada no eDocs novamente no Gestão Empresarial | ERP, agora para um diretório que não integra com o eDocs.