ERP – eDocs NF-e – Rejeição 539: Duplicidade de NF-e com diferença na Chave de Acesso [chNFe: 99999999999999999999999999999999999999999999][nRec:999999999999999]
Incidente
Ao emitir uma nota, no eDocs em NF-e / Emissões, aba Emissões, o documento está retornando com status rejeitado da SEFAZ e na tela de Eventos é apresentado a seguinte informação: Rejeição 539: Duplicidade de NF-e com diferença na Chave de Acesso [chNFe: 99999999999999999999999999999999999999999999][nRec:9999999999999 99].
Causa
Essa situação ocorre quando for emitida uma NF-e e na SEFAZ já existir outra NF-e, já autorizada, com o mesmo CNPJ Emitente, Modelo, Série e Número, mas com, Data de Emissão, Tipo de Emissão ou Código Numérico ou outras posições da Chave de Acesso diferentes.
Conforme consta no MOC 7.0 - Anexo I do Leiaute e Regra de Validação da SEFAZ:
Essa situação pode se encaixar nos seguintes cenários:
- Ao realizar o envio de uma NF-e com tipo Normal de emissão, foi identificado uma instabilidade na comunicação com a SEFAZ e o retorno indicando que a NF-e foi recebida ou está em processamento não é retornado ao eDocs, apesar da SEFAZ ter recebido a NF-e e autorizado a mesma. Nessa situação, o usuário ativa a contingência no eDocs e reenvia a NF-e que é recebida pela SEFAZv com a chave de acesso em contingência. Quando a SEFAZ restabelece seus serviços e recebe a NF-e com a chave de acesso diferente retorna a crítica para o sistema;
- Ao realizar o envio de uma NF-e, antes que a SEFAZ devolva o retorno do documento é reenviado a mesma NF-e, mas com a tag <cNF> (Código Numérico) diferente do <cNF> do primeiro envio. O Código Numérico da NF-e é parte integrante da chave de acesso, causando desta forma o retorno de rejeição também;
- Foi emitida uma NF-e no ano de 2008 com a numeração 1 e série 1. No ano seguinte a mesma numeração e série foram usadas para a emissão de uma nova NF-e. Como o Ano faz parte da composição da chave de acesso, haverá diferença e será retornado rejeição para o sistema.
Solução
Para verificar essa situação, verifique as orientações abaixo:
1. Na rejeição retornada pela validação da SEFAZ, existe uma chave de acesso que corresponde a nota fiscal que já existe na SEFAZ com os mesmos campos-chaves. Copie essa chave e consulte a mesma no portal da SEFAZ:
- Clique aqui para acessar o portal de consulta do ambiente de produção;
- Clique aqui para acessar o portal de consulta do ambiente de homologação;
1.1. Ao consultar a chave de acesso, valide as informações da nota fiscal, se o que consta no portal da SEFAZ confere com a nota que está sendo rejeitada pela SEFAZ (cliente, produtos, valores, tipo de emissão, etc);
1.2 Se as informações foram iguais, siga as orientações a seguir para corrigir o status do documento no eDocs e Gestão Empresarial | ERP:
1.2.1. Acesse a tela F099UVE - Cadastros / Usuários / Parâmetros por Gestão / Vendas, Faturamento e Transporte e altere o campo Diretório Arquivo NF-e para um caminho que não integre com o eDocs:
1.2.2. Acesse a tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal e emita a nota novamente, de forma que a situação da nota no ERP fique como 2 (documento emitido;
1.2.3. Efetue um update na base do Gestão Empresarial | ERP e altere a chave de acesso (CHVDOE) para a chave de acesso que está autorizada na SEFAZ:
UPDATE
E140IDE
SET
CHVDOE = 'XXX'
WHERE
CODEMP = X AND
CODFIL = X AND
NUMNFV = XXX AND
CODSNF = 'XX'
1.2.4. Efetue um update na base do eDocs, alterando a chave de acesso (IDENFE e IDEERP, tabela N130NFE) para a chave de acesso que está autorizada na SEFAZ:
SELECT
*
FROM
N130NFE
WHERE
NUMNFE = XXX AND
SEQFIL = 'CNPJ_FILIAL'
Salve a informação que retornar no campo SEQNFE para usar no update abaixo:
UPDATE
N130NFE
SET
IDENFE = 'XXX',
IDEERP = 'XXX'
WHERE
SEQNFE = 'XXX' AND
SEQFIL = 'CNPJ_FILIAL'
1.2.5. Confira na base de dados do eDocs, na tabela N130NFE o campo DIGVAL se está preenchido com o mesmo dígito verificador presente na consulta da nota no Portal da SEFAZ, se estiver diferente, alterar conforme está na SEFAZ;
SELECT
*
FROM
N130NFE
WHERE
NUMNFE = XXX AND
SEQFIL = 'CNPJ_FILIAL'
Salve a informação que retornar no campo SEQNFE para usar no update abaixo:
UPDATE
N130NFE
SET
DIGVAL = 'XXX'
WHERE
SEQNFE = 'XXX' AND
SEQFIL = 'CNPJ_FILIAL'
1.2.6. Acesse no eDocs a tela NF-e / Emissões, aba Emissões, selecione a nota e clique no botão Consultar;
A nota será consultada na SEFAZ (com a chave correta) e será retornada a autorização para o eDocs e consequentemente para o Gestão Empresarial | ERP.
1.2.7. Acesse novamente a tela F099UVE - Cadastros / Usuários / Parâmetros por Gestão / Vendas, Faturamento e Transporte e remova o conteúdo preenchido no campo Diretório Arquivo NF-e;
1.3. Se as informações da nota na SEFAZ forem diferentes da nota que está tentando emitir, verifique no Gestão Empresarial | ERP a revisão do CNPJ Emitente, Modelo, Série e Número.
Observação
- Se a nota está autorizada em dois ambientes (normal e contingência por exemplo), é necessário verificar com a SEFAZ Estadual qual nota será mantida no Portal para posteriormente ajustar os dados no ERP e eDocs;
- É indicado realizar os ajustes da nota em um momento em que a empresa não estiver realizando faturamento de outros documentos;
- Caso necessário, uma nova série fiscal poderá ser cadastrada no Gestão Empresarial | ERP pela tela F020SNF - Cadastros / Mercado e Suprimentos / Parâmetros Fiscais / Séries Notas Fiscais / Cadastro para emissão das notas fiscal;
- O eDocs já possui parametrização para parar o envio dos documentos em caso de instabilidade da SEFAZ, ou seja, os documentos que estiverem em processamento e sofrer alguma instabilidade na conexão ficam com o status aguardando consulta até a SEFAZ normalizar. Para mais informações, clique aqui e acesse o Portal de Documentação Senior, pesquise por "Parar envio de documentos em períodos de instabilidade de conexão" e localize a documentação completa desta rotina no módulo de Configurações de Filiais do eDocs.