ERP – eDocs Emissão/Recebimento – Rejeição 217: NF-e não consta na base de dados da SEFAZ
Incidente
Na emissão ou recebimento de NF-e no eDocs, a nota está retornando com status rejeitado da SEFAZ e na tela de Eventos é apresentado a seguinte informação: Rejeição 217: NF-e não consta na base de dados da SEFAZ.
Observação
Essa rejeição pode ocorrer também para os demais tipos de documentos eletrônicos, por exemplo: CT-e e MDF-e.
Causa
Essa situação ocorre quando:
- A NF-e é emitida em produção e a chave de acesso é consultada em homologação e vice-versa;
- A NF-e ainda não foi autorizada pela SEFAZ e a chave de acesso é consultada no webservice;
Solução
Nos casos onde o eDocs receber essa rejeição da SEFAZ, deverá ser verificado:
1. Se a NF-e for Emissão:
1.1. Acesse o portal Estadual da SEFAZ e realize a consulta pela chave de acesso da NF-e;
1.2. Se a nota existir, acesse o eDocs em NF-e / Emissões, aba Emissões selecione a nota e clique no botão Consultar;
1.3. Se a nota não existir, acesse o Gestão Empresarial | ERP e emita a nota novamente pela tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal;
2. Se a NF-e for Recebimento:
2.1. Acesse o portal Estadual da SEFAZ de origem da NF-e e realize a consulta pela chave de acesso do documento;
2.2. Se a nota não existir no sistema da SEFAZ (via site), indica que a SEFAZ não possui este documento registrado em seu sistema. Neste caso, abra um protocolo de verificação junto a SEFAZ;
2.3. Se a nota existir no portal da SEFAZ, acesse o eDocs em NF-e / Emissões, aba Emissões selecione a nota e clique no botão Consultar;
3. Para comparar as URL do webservice que estão no eDocs X o que consta no portal da SEFAZ:
3.1. Acesse no eDocs a tela Configurações / Consulta URLs e filtre a UF de origem da NF-e;
3.2. Acesse o portal de SEFAZ e localize a UF de origem da NF-e:
- Para acessar o ambiente de produção da NF-e clique aqui;
- Para acessar o ambiente de homologação da NF-e clique aqui;
Importante
- Se o WebService no site da SEFAZ for diferente do WebService que o eDocs utilizou para a consulta, deverá ser aberto um ticket para o Suporte da Senior verificar a situação;
- Deverá sempre ser efetuada a comparação entre as URLs dos webservices de acordo com a versão do documento e o ambiente (produção ou homologação - lembrando que os sites da SEFAZ de homologação mudam também);
- Caso a empresa utilize a integração com o ERP Senior para recebimento de documento eletrônicos, enquanto a situação está sendo avaliada, poderá ser efetuado o envio do XML para o ERP através do modo MCDebug (para mais informações sobre o processo, clique aqui e acesse o Portal de Documentação Senior, pesquise por "Retorno manual via MCDebug" e localize a documentação completa desta rotina no módulo eDocs.