ERP – eDocs Comunicação SEFAZ/Prefeitura – Falhas na Comunicação com SEFAZ/Prefeitura (The operation has timed out / The request was canceled / Unable to connect to the remote server)
Incidente
No processo de comunicação do eDocs com SEFAZ/Prefeitura, a comunicação não ocorre adequadamente, sendo que os documentos ficam com status intermediários (Validada, Gerada, Enviada, ...) e são exibidas mensagens no Monitor ou Log do eDocs conforme exemplos abaixo:
- The operation has timed out;
- System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <IP_Destino>;
- The request was aborted: The request was canceled;
- O tempo limite da operação foi atingido;
- Established connection failed because connected host has failed to respond.
Observação:
- O problema pode ocorrer no envio ou consulta de vários documentos eletrônicos para SEFAZ/Prefeitura, sendo que a mensagem de erro pode variar um pouco de acordo com o documento eletrônico;
- O IP indicado na mensagem de erro pode variar de acordo com o IP do WebService que está sendo contatado para envio do documento.
Causa
A situação pode ocorrer por duas questões:
- Problemas no WebService da SEFAZ/Prefeitura;
- Problemas de infraestrutura do cliente, onde no ambiente do mesmo, o eDocs não está conseguindo efetuar conexão com o WebService da SEFAZ/Prefeitura. Isso geralmente ocorre quando os serviços do eDocs não estão sendo executados com usuário administrado da rede/domínio/servidor que possui acesso irrestrito à internet, ou quando o Firewall/Proxy do cliente não está devidamente parametrizado no ambiente do cliente e nas parametrizações de proxy do eDocs.
Solução
Para solucionar essa situação, valide os procedimentos abaixo:
1. Para questões relacionadas ao WebService da SEFAZ/Prefeitura:
1.1. Entre em contato com a SEFAZ/Prefeitura para verificar se os serviços do webservice estão todos OK;
1.2. Entre em contingência no eDocs, caso necessário, para emissão dos documentos. Para maiores informações sobre como ativar contingência, consulte as documentações abaixo:
- NF-e: Clique aqui para acessar a Documentação completa sobre uso de contingência no eDocs;
- CT-e: Clique aqui para acessar a Documentação completa sobre uso de contingência no eDocs;
- MDF-e: Clique aqui para acessar a Documentação completa sobre uso de contingência no eDocs;
- NFC-e: Clique aqui para acessar a Documentação completa sobre uso de contingência no eDocs.
2. Para questões relacionadas a Infraestrutura:
2.1. Valide se as configurações no IIS estão conforme orientação da documentação do sistema eDocs. Para maiores informações sobre a correta parametrização do IIS, verifique o artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs;
Importante:
- A situação em questão não é um problema do sistema eDocs;
- O eDocs utiliza a parametrização de Proxy tanto para acesso externo (acesso aos WebServices da SEFAZ/prefeitura) quanto para o acesso interno (acesso à Intranet - SeniorSID - WebServices do ERP). Sendo assim, o proxy do cliente deverá estar devidamente parametrizado para que, quando o eDocs utilizar o Proxy, o mesmo tenha tanto acesso interno como acesso externo;
- Essa situação também pode ocorrer na consulta de documentos eletrônicos ou qualquer outro processo que exija conexão do eDocs com o WebService da SEFAZ/Prefeitura.