ERP – Faturamento – Rejeição RPS/NFS-e: Código CNAE inexistente
Incidente
Ao emitir uma NFS-e, a mesma está retornando como rejeitada da Prefeitura com o seguinte motivo: Código CNAE inexistente.
Causa
A rejeição Código CNAE inexistente é uma rejeição da própria Prefeitura. Essa situação ocorre quando a Prefeitura entende que o código CNAE enviado é inválido ou o emitente da RPS/NFS-e não possui vínculo com CNAE informado no documento eletrônico que foi enviado.
Solução
Para verificar este cenário, realize os passos a seguir:
1. Acesse a tela F070FCT - Cadastros / Filiais / Parâmetros por Gestão / Contabilidade, aba Contábil 2 e verifique se o cadastro do CNAE está de conforme o CNAE principal da filial emitente da RPS/NFS-e;
2. Após realizar as devidas validações, acesse a tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal e emita a nota novamente.
Observação
- Se o CNAE que está sendo enviado no documento eletrônico está vinculado ao CNPJ da filial no sistema da Prefeitura (esta verificação deverá ser efetuada diretamente no sistema da Prefeitura - em caso de necessidade de apoio, deverá ser contatado o suporte do sistema da Prefeitura);
- O identificador de regras GER-000ABRASF1 possibilita a alteração do código CNAE (tag <CNAE> do XML da RPS/NFS-e gerado pelo ERP). Esta alteração é efetuada através da manipulação da variável 'VSIntCodCna' disponível no identificador citado. Quando necessário é possível retornar um valor em branco para essa variável (VSIntCodCna= ) para que a tag não seja gerada;
- Caso haja necessidade de ser verificado qual o código CNAE enviado para a Prefeitura pelo eDocs, devera ser coletado o Log XML da RPS/NFSe. Para mais informações consulte o artigo ERP – eDocs Log XML – Como coletar os XMLs trafegados entre eDocs e SEFAZ/Prefeituras (Logs XML);
- Código da atividade (ou Item da Lista de Serviço) é diferente do código CNAE. Desta forma, o código do CNAE não deve ser preenchido com o código da atividade ou código do Item da Lista de Serviço;
- Algumas Prefeituras possuem a tag <CNAE> em seu leiaute de integração, no entanto não aceitam o envio da informação do CNAE, gerando a mensagem de rejeição indicada. Nestes casos, se os códigos estão sendo enviados corretamente para a Prefeitura, então deverá ser contatado o Suporte do sistema da Prefeitura para verificar o motivo pelo qual a Rejeição está sendo gerada.