ERP – eDocs Impressão – Não foi possível imprimir o <Documento> número X / A definição do relatório '\' é inválida / Erro inesperado durante a compilação das expressões. Valor de retorno do compilador nativo: '-1073741502'
Incidente
Ao solicitar impressão ou geração de algum PDF através do eDocs é gerada a seguinte mensagem em tela: Não foi possível imprimir o <Documento> número X. Verifique o arquivo de log para maiores informações.
No log (Sde.log) é registrado a seguinte informação: Senior.SapiensNfe.Processos.Service.DocumentoAuxiliar.RelatorioControlador - Não foi possível gerar PDF para o documento auxiliar.
Microsoft.Reporting.WinForms.LocalProcessingException: Ocorreu um erro durante o processamento de relatórios local. ---> Microsoft.Reporting.DefinitionInvalidException: A definição do relatório '\' é inválida. ---> Microsoft.ReportingServices.ReportProcessing.ReportPublishingException: Erro inesperado durante a compilação das expressões. Valor de retorno do compilador nativo: '-1073741502'.
Observação
Dependendo da versão do Microsoft Windows do servidor onde o sistema eDocs está instalado, a mensagem poderá ser apresentada em outro idioma.
Causa
Essa situação ocorre por problemas relacionados ao IIS e aos componentes do framework .NET da Microsoft.
Solução
Para verificar esta situação, verifique as orientações a seguir:
1. Solicite a um profissional que tenha domínio nos componentes do IIS e do Microsoft .NET que realize uma análise do ambiente;
2. Após a atuação do profissional, realize novamente a geração do PDF.
Importante
- Em alguns casos, o reinício do servidor onde o eDocs está instalado pode resolver a situação;
- Como se trata de um problema estritamente voltado a ambiente, caso haja necessidade de apoio para verificação de ambiente, a área de Serviços da Senior poderá ser contatada para alocação de um consultor de TI;
- Para comprovar se o problema está relacionado ao ambiente, pode-se efetuar a restauração da base de dados do eDocs e dos templates utilizados em um outro ambiente e executar o mesmo processo para garantir que o processo de geração do PDF está funcionando adequadamente;
- Caso você utilize solução eDocs SAAS (ambiente Cloud da Senior), acione a equipe de IT Services para verificar essa situação.