ERP – eDocs Comunicação SEFAZ/Prefeitura – Problemas de comunicação (Unable to read data from the transport connection / Could not create SSL/TLS secure channel / A solicitação foi anulada)
Incidente
Ao enviar documentos (NF-e, NFS-e, CT-e, MDF-e, entre outros) para autorização da SEFAZ/Prefeitura ou ainda realizar qualquer comunicação com a SEFAZ/Prefeitura (exemplo: Consulta de NF-e recebida), o status do documento no eDocs permanece como: Enviado SEFAZ, Recebido ERP ou Validado e no do eDocs é possível encontrar mensagens conforme abaixo:
- The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host;
- A conexão subjacente estava fechada: Erro inesperado em um envio. ---> System.IO.IOException: Falha na autenticação porque o participante remoto fechou o fluxo de transporte;
- Erro ao consultar situação de NF-e, número sequencial: NúmeroSequencial>System.Net.WebException: The operation has timed out;
- A conexão subjacente estava fechada: Erro inesperado em um envio. ---> System.IO.IOException: Não é possível ler os dados da conexão de transporte: Foi forçado o cancelamento de uma conexão existente pelo host remoto. ---> System.Net.Sockets.SocketException: Foi forçado o cancelamento de uma conexão existente pelo host remoto;
- Erro ao enviar lote de RPS. System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Authentication failed because the remote party has closed the transport stream.
- The request was aborted: Could not create SSL/TLS secure channel. A solicitação foi anulada: Não foi possível criar um canal seguro para SSL/TLS
- Ocorreu um erro ao atualizar o Status da Nota: Solicitação foi anulada: Não foi possível criar um canal seguro para SSL/TLS;
- Não foi possível atualizar a situação do documento. A solicitação foi anulada: Não foi possível criar um canal seguro para SSL/TLS;
- Não foi possível atualizar a situação do documento: an internal error occured;
- A conexão subjacente estava fechada: Erro inesperado em um recebimento. ---> System.IO.IOException: Não é possível ler os dados da conexão de transporte: Uma conexão estabelecida foi anulada pelo software no computador host. ---> System.Net.Sockets.SocketException: Uma conexão estabelecida foi anulada pelo software no computador host.
- A conexão subjacente estava fechada: Erro inesperado em um recebimento. ---> System.IO.IOException: Não é possível ler os dados da conexão de transporte: Uma conexão estabelecida foi anulada pelo software no computador host. ---> System.Net.Sockets.SocketException: Uma conexão estabelecida foi anulada pelo software no computador host;
- System.Net.WebException: Impossível conectar-se ao servidor remoto ---> System.Net.Sockets.SocketException: Uma tentativa de conexão falhou porque o componente conectado não respondeu corretamente após um período de tempo ou a conexão estabelecida falhou porque o host conectado não respondeu IP;
- Impossível conectar-se ao servidor remoto ---> System.Net.Sockets.SocketException: Uma tentativa de conexão falhou porque o componente conectado não respondeu corretamente após um período de tempo ou a conexão estabelecida falhou porque o host conectado não respondeu IP.
Esse cenário poderá ocorrer em diversos processos, exemplos:
- Emissão de documentos (NF-e, NFS-e, CT-e, MDF-e, NFC-e);
- Recebimento de documentos, onde é efetuada a consulta do status do documento na SEFAZ;
- Consulta de manifestações de destinatário na SEFAZ; entre outros.
Causa
A situação é causada devido a uma incapacidade do sistema eDocs em conseguir comunicação com a SEFAZ/Prefeitura, seja por um problema de infraestrutura onde o eDocs está instalado ou algum tipo de instabilidade dos webservices da SEFAZ/Prefeitura.
Pode ocorrer por problemas no ambiente onde o sistema está instalado, podendo estar relacionado a alguma permissão de proxy/firewall ou então há alguma parametrização dos serviços do IIS. Ou também pode ocorrer quando há problemas com o WebService da SEFAZ/Prefeitura, onde o mesmo encontra-se instável ou indisponível.
Solução
Seguem validações a serem realizadas para sanar essa situação:
1. Efetue contato com a SEFAZ/Prefeitura para verificar instabilidades em seus webservices. Muitas vezes, estes órgãos disponibilizam em seus sites informações sobre instabilidades em seus serviços. Instabilidades nesses serviços podem ocasionar problemas de comunicação com os mesmos.
2. Valide se todas as configurações de ambiente para correta utilização do eDocs estão realizadas corretamente, conforme artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs
3. Valide se o campo 'Configuração SSL/TLS' está preenchido corretamente no eDocs na tela Configurações / Gerais, aba Avançado, sub-aba Conexão:
Observação:
- A configuração desse parâmetro deve ser realizada levando em consideração o protocolo de Segurança que os WebServices utilizados pelas Prefeituras/SEFAZ estão utilizando., Atualmente praticamente todos os WebServices utilizam protocolo TLS, e muitos deles já exigem o protocolo TLS 1.2. Então, nesses casos, as opções 'TLS 1.0', 'TLS 1.1' e 'TLS 1.2' devem ser marcadas.
- Após a alteração deste parâmetro é necessário reiniciar a aplicação (serviço Windows ou IIS).
3. Valide também se não existe nenhum problema de infraestrutura no Servidor onde o eDocs está instalado. Isso deve ser verificado pelo responsável pela infraestrutura onde o eDocs está instalado.
3.1. Solicite ao responsável pela Infraestrutura do ambiente onde o sistema eDocs está instalado realizar uma avaliação, garantindo que todas as permissões para a correta comunicação com os Webservices da SEFAZ estejam OK;
3.2. Acesse a tela Configurações / Consulta de URL e verifique se todos os WebServices da SEFAZ/Prefeitura estão acessíveis a partir do servidor do eDocs. O teste deverá ser efetuado utilizando navegador Web do servidor.
Importante:
- Para a rotina de recebimento, o eDocs também utiliza os WebServices da SEFAZ aonde a NF-e/CT-e foi emitida. Neste caso, por exemplo, se o fornecedor do cliente emitiu a NF-e na SEFAZ de SP e o cliente utiliza a SEFAZ de SC para emissão de seus documentos, o acesso aos WebServices tanto de SP quando ao de SC devem estar liberados e acessíveis no ambiente do cliente. Sendo assim, o teste solicitado no procedimento anterior também deve ser feito caso os fornecedores do cliente (emitentes das NF-e que não estão sendo consultadas) utilizem serviços de uma SEFAZ diferente da do cliente;
- O eDocs utiliza a parametrização de Proxy tanto para acesso externo (acesso aos WebServices da SEFAZ/Prefeitura) quanto para o acesso interno (acesso à Intranet - SeniorSID - WebServices do ERP). Sendo assim, o proxy do cliente deverá estar devidamente parametrizado para que, quando o eDocs utilizar o Proxy, o mesmo tenha tanto acesso interno como acesso externo;
- Enquanto que a situação não é resolvida, pode-se ativar a contingência se necessário. Clique aqui e acesse o Portal de Documentação Senior, pesquise por "controle de contingência" e localize a documentação completa desta rotina nos módulos de NF-e, CT-e e MDF-e;
- Ao entrar em contingência é extremamente recomendado habilitar o parâmetro 'Parar envio de documentos em períodos de instabilidade de conexão' da tela Configurações / Filiais, aba NF-e, sub-aba Geral. Com este parâmetro ativo, diante da SEFAZ instável, impede que o sistema envie a mesmo documento para ambiente normal e ambiente de contingência, o que ocasionaria problemas futuros. Clique aqui e acesse o Portal de Documentação Senior, pesquise por "Parar envio de documentos em períodos de instabilidade de conexão" e localize a documentação completa desta rotina no produto eDocs;
- Caso hajam documentos emitidos na SEFAZ e sem retorno para o eDocs, deve-se aguardar o retorno da autorização e não deve ser enviada para contingência, pois é provável que a SEFAZ já tenha autorizado e não retornou a autorização devido a esta instabilidade. Caso haja urgência para autorização deste documento, pode-se emitir um novo documento no Gestão Empresarial | ERP, agora com o eDocs definido para utilizar algum tipo de contingência, e, posteriormente, quando o primeiro documento for autorizado, solicitar o cancelamento deste documento.
- Essa situação trata-se de algo relacionado a infraestrutura e/ou problemas nos WebServices da SEFAZ/Prefeitura. Caso haja necessidade de apoio para avaliação da situação, poderá ser solicitado à área de Serviços da Senior um consultor de TI para análise da situação.