ERP – eDocs NF-e – Crítica: 1168 - Falha no processamento / Erro ao obter retorno do recibo: - System.IO.IOException: Nome de usuário ou senha incorretos
Incidente
Ao emitir NF-e, a mesmo está sendo marcada como Falha sem nenhuma descrição de detalhes da crítica. Ao clicar em Reprocessar na tela de Eventos para cada uma das NF-e, a nota é enviada novamente para a SEFAZ e ela é Autorizada, mas em seguida ela é retornada para Falha. Neste momento, a seguinte descrição detalhada da crítica é informada:
Evento: Falha
Críticas
Crítica: 1168 - Falha no processamento
Detalhe Crítica
Erro ao obter retorno do recibo: - System.IO.IOException: Nome de usuário ou senha incorretos.
em System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
em System.IO.Directory.InternalCreateDirectory(String fullPath, String path, DirectorySecurity dirSecurity)
em System.IO.Directory.CreateDirectory(String path, DirectorySecurity directorySecurity)
em Inventti.NfePackBusiness.Service.ObterRetornoLoteBusiness.SalvarXmlAssinadoDisco(XmlDocument xmlNfe, TNFeBase nfe, EstabGerdor estabGerdor)
em Inventti.NfePackBusiness.Service.ObterRetornoLoteBusiness.GeraXmlNFeAutorizada(EstabGerdor estabGerdor, protNFe protNFe, ItemLoteNfe itemLote, TNFeBase nfe)
em Inventti.NfePackBusiness.Service.ObterRetornoLoteBusiness.AtualizaNotaAprovada(EstabGerdor estabGerdor, Dictionary`2 pacoteVersao, protNFe protNFe, ItemLoteNfe itemLote, Boolean enviarEmail, StatusNfeEnum situacao)
em Inventti.NfePackBusiness.Service.ObterRetornoLoteBusiness.ObterReci
Soluções: Reprocesse o documento
Causa
Essa situação ocorre por inconsistências no ambiente onde está a instalação do eDocs.
Solução
Para tratar essa situação, verifique as orientações abaixo:
1. Verifique se os serviços do eDocs estão parametrizações corretamente conforme o artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs;
2. Verifique se o usuário que está instanciando os serviços do eDocs possui permissão para acessar/gravar documentos no diretório de integração parametrizado no cadastro da Filial;
3. Até resolver a situação, desative temporariamente em Configurações / Gerais, aba Geral o campo 'Armazenar XML processado em disco';
4. Acesse a tela NF-e / Emissões, aba Emissões e reprocesse a nota novamente.
Observação
- Ao ser efetuado o reprocessamento novamente, a NF-e pode ficar travada com status de 'Enviada SEFAZ'. Se isto ocorrer, entre em contato com Suporte para avaliação do cenário.