ERP – eDocs Retorno de Documentos – Impossível conectar-se ao servidor remoto ---> System.Net.Sockets.SocketException: Nenhuma conexão pôde ser feita porque a máquina de destino as recusou ativamente <IP_e_Porta_Servidor>
Ao ser emitido uma NF-e, no eDocs na tela NF-e / Emissões, aba Emissões, o indicativo de retorno ao Gestão Empresarial | ERP está como pendente:

No arquivo de log (Sde.log) é apresentado a seguinte informação: Impossível conectar-se ao servidor remoto ---> System.Net.Sockets.SocketException: Nenhuma conexão pôde ser feita porque a máquina de destino as recusou ativamente <IP_e_Porta_Servidor>.
Importante
Essa situação pode ser apresentada para qualquer documento fiscal entre NF-e, CT-e, MDF-e ou NFS-e, tanto para emissão quanto para Recebimento.
Causa
Essa situação ocorre quando há inconsistências na comunicação do Glassfish/Middleware entre o servidor do eDocs e do Gestão Empresarial | ERP, podendo estar relacionado a configurações indevidas ou a problemas de infraestrutura.
Solução
Para este cenário, seguem verificações a serem efetuadas:
1. Verifique se o Middleware Senior está instanciado e acessível através do servidor do eDocs;
2. Efetue testes de retorno via MCDebug a partir do servidor do eDocs para garantir a comunicação dos WebServices do ERP. Para mais informações sobre como realizar o procedimento, clique aqui para consultar documentação completa;
3. Verifique as parametrizações de retorno no eDocs:
3.1. Acesse a tela Configurações / Empresa, aba Integração e verifique a URL preenchida no campo URL Web Service integração ERP. Clique no campo Clique para abrir para verificar se a mesma está ativa:

Deverá ser aberto uma página conforme exemplo abaixo:

3.1.1. Verifique se o Deploy do webservice foi realizado. No final da URL acrescente a informação /g5-senior-services/sapiens_Synccom_senior_g5_co_int_eletronicos_documentos?wsdl conforme exemplo: http://servidor_Middleware:8080/g5-senior-services/sapiens_Synccom_senior_g5_co_int_eletronicos_documentos?wsdl
Onde deverá ser aberto uma tela conforme exemplo abaixo:

3.2. Se os webservices de retorno de situação dos documentos está utilizando o padrão W3C nas URLs, ative o campo 'ERP usa padrão W3C nas URLs' em Configurações / Empresas, aba Integração;
4. Verifique a necessidade de parametrização de Proxy no eDocs para atendimento dos requisitos da infraestrutura (caso necessário), em Configurações / Gerais, aba Opções da Internet:

5. Verifique se existe algum proxy ou firewall no ambiente que estaria impedindo a comunicação do eDocs com o Middleware Senior;
Importante
- Os serviços do eDocs devem estar sendo instanciados com usuário administrador da rede/domínio. A não utilização do usuário com estas credenciais poderá ocasionar diversos problemas na execução dos processos do eDocs;
- A mensagem de erro informada indica problemas de comunicação do eDocs com o WebService do Gestão Empresarial | ERP devido à parametrizações incorretas ou problemas da infraestrutura. Não estando relacionado a uma falha do eDocs.