HCM - Gestão de Ponto - Erro na Integração do Webservice de Gestão de Ponto
Incidente
Ao realizar a chamada de webservices do Gestão de Ponto, o log de processamento apresenta a seguinte mensagem:
O Empregado xxx da Empresa xxx não foi processado no fechamento do banco de horas do módulo Gestão de Ponto. Erro ao chamar serviço.
URL: http://servidor:8082/g-senior-services/gestaoponto FechamentoBanco.
Possivel causa: Servidor inativo, inacessível ou URL inválida... Para maiores
Causa
Esta mensagem é retornada, pois o proxy está bloqueando a conexão entre Middleware e Wildfly.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Verifique se o Middleware e o Wildfly estão configurados corretamente;
2. Verifique se os WSDLs estão acessíveis;
3. Acesse o SeniorConfigCenter, Conexões de Rede / Acesso à Internet, na grid "Não utilizar proxy para os endereços iniciados com", clique em adicionar;

4. Insira o endereço do servidor do Gestão do Ponto;
5. Salve as alterações e reinicie os serviços do SeniorInfo, Middleware e Wildfly, nesta ordem;
6. Aguarde uns minutos para que os serviços sejam iniciados corretamente, e realize a chamada novamente.